【POJ P2411】【状压DP】Mondriaan‘s Dreamk

Mondriaan's Dream

POJ P2411 Mondriaan’s Dreamk


题目

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
在这里插入图片描述

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
在这里插入图片描述

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

在这里插入图片描述


解题思路

设 f[i][j] 表示到第 i 行摆放方式为 j 的方案数
摆放状态用10表示

  • 1表示这里需要竖放向下突一格,当然要保证上行是0,一个0一个1用判断即可
  • 0有两种情况,一种是上行的这个位置是1,与上行并在一起
    还有就是要和左/右格并成一个横放,这里就必须要保证连在一起的0是偶数位,而且上行没有1凸出来拦截,可以提前预处理出‘0偶’的状态,然后在判断上行和下行出来是不是合法状态即可

Code

#include <iostream>
#include <cstring>
#include <cstdio>
#define ll long long

using namespace std;

ll n, m, f[20][1 << 15], c[1 << 15];

int main() {
	scanf("%lld %lld", &n, &m);
	while(n || m) {
		memset(c, 0, sizeof(c));
		for(int i = 0; i < (1 << m); i ++) {
			c[i] = 1;
			for(int j = 1; j <= m; j ++) {
				if((i >> (j - 1)) & 1) continue;
				int cnt = 1;
				while(j < m && !((i >> j) & 1)) j ++, cnt ++;  //统计 0 的个数
				if(cnt & 1) { c[i] = 0; break; }
			}
		}
		memset(f, 0, sizeof(f));
		f[0][0] = 1;
		for(int i = 1;  i <= n; i ++) {
			for(int x = 0; x < (1 << m); x ++) {  //上一行状态
				if(!f[i - 1][x]) continue;
				for(int y = 0; y < (1 << m); y ++)  //当前行状态
					if(!(x & y) && c[x | y]) f[i][y] +=f[i - 1][x];  //没有两个 1 ,且连在一起的 0 是合法的
			}
		}
		printf("%lld\n", f[n][0]);  //最后一行当然不能有凸下去的 1
		scanf("%lld %lld", &n, &m);
	}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值