03 List Leaves (java实现)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

在这里插入图片描述

Sample Output:

4 1 5

问题分析

题目要求:

1、按层序遍历二叉树
2、在此基础上,输出叶子节点

步骤:

与前面同构树的判断类似
1、使用buildtree建立二叉树。由于题目中只给出了左右节点位置,设置节点本身的位置使用element接收,且使用0~7进行位置赋值
2、进行二叉树层序遍历时,采取队列操作,因为队列操作符合层序遍历的顺序特点(先进先出)
使用与课本中类似代码,只是在输出时,需要判断,节点的左右子树是否全部为空,即等于-1

import java.util.*;
public class ListLeavesDemo 
{
	public static void main(String[] args) 
	{
		Scanner scan = new Scanner(System.in);
		int N = Integer.parseInt(scan.nextLine());	//要输入的数值的数量
		TreeNode[] T= new TreeNode[N];
		int root = BuildTree(scan,N,T);		//根节点的位置

		PrintLeaves(root, T);
	}

	public static int BuildTree(Scanner scan, int N, TreeNode[] T){				

		int[] check = new int[N];					
		for(int i=0; i<N; i++){
				check[i] = 0;		                //使用check判别根节点,若check[i]为0,则i为root根节点
		}
		
			for(int i=0; i<N; i++){
				T[i] = new TreeNode();
				T[i].element = i;

				String[] c = scan.nextLine().split(" ");
				if(!c[0].equals("-")){
					T[i].left = Integer.parseInt(c[0]);
					check[T[i].left] = 1;
				}else{
					T[i].left = -1;
				}

				if(!c[1].equals("-")){
					T[i].right = Integer.parseInt(c[1]);
					check[T[i].right] = 1;
				}else{
					T[i].right = -1;
				}

			}
		//根节点查找
			int root = -1;
			for(int i=0; i<N; i++){
				if(0==check[i]){
					root = i;
					break;
				}
			}
			return root;	
	}

	public static void PrintLeaves(int root, TreeNode[] T){
	//使用队列进行二叉树的层序遍历
		Queue<Integer> queue = new LinkedList<Integer>();

		if(root==-1){
			System.out.println("树为空");
			return;
		}
		
		queue.offer(T[root].element);
		while(!queue.isEmpty()){
			int t = queue.peek();
			queue.remove();

			if((T[t].left==-1)&&(T[t].right==-1)){
				System.out.println(t);
			}
			if(T[t].left!=-1){
				queue.offer(T[T[t].left].element);
			}
			if(T[t].right!=-1){
				queue.offer(T[T[t].right].element);
			}
		}


	}
}

class TreeNode{
	public int element;
	public int left;
	public int right;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值