求三角形面积
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description
已知三角形的边长a、b和c,求其面积。
Input
输入三边a、b、c。
Output
输出面积,保留3位小数。
Example Input
1 2 2.5
Example Output
0.950
Hint
Author
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
double x1 = 0,x2 = 0;
void jisuan(double a,double b,double c)
{
double d = 0.5*(a+b+c),s;
s = d*(d-a)*(d-b)*(d-c);
s = sqrt(s);
printf("%.3lf\n",s);
}
int main()
{
double a,b,c;
scanf("%lf %lf %lf",&a,&b,&c);
jisuan(a,b,c);
return 0;
}