求三角形面积

求三角形面积

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

已知三角形的边长a、b和c,求其面积。

Input

输入三边a、b、c。

Output

输出面积,保留3位小数。

Example Input

1 2 2.5

Example Output

0.950

Hint
Author

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
double x1 = 0,x2 = 0;
void jisuan(double a,double b,double c)
{
    double d = 0.5*(a+b+c),s;
    s = d*(d-a)*(d-b)*(d-c);
    s = sqrt(s);
    printf("%.3lf\n",s);

}
int main()
{
    double a,b,c;
    scanf("%lf %lf %lf",&a,&b,&c);
    jisuan(a,b,c);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值