最长公共子序列问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
给定两个序列 X={x1,x2,…,xm} 和 Y={y1,y2,…,yn},找出X和Y的最长公共子序列。
Input
输入数据有多组,每组有两行 ,每行为一个长度不超过500的字符串(输入全是大写英文字母(A,Z)),表示序列X和Y。
Output
每组输出一行,表示所求得的最长公共子序列的长度,若不存在公共子序列,则输出0。
Sample Input
ABCBDAB
BDCABA
Sample Output
4
Hint
Source
注意dlong不能开的太大,我开到了1000,就直接运行不了了就,后来改为500就正常了。
#include <bits/stdc++.h>
using namespace std;
int main()
{
char a[1000];
char b[1000];
int dlong[505][505]; //用来表示a数组的第i个字符与b数组的第j个字符的最长公共子序列
while(cin>>a>>b)
{
memset(dlong,0,sizeof(dlong));
//注意初始化,dlong[i][0] = dlong[0][j] = 0;
for(int i = 1; i <= strlen(a); i++)
{
for(int j = 1; j <= strlen(b); j++)
{
if(a[i-1] == b[j-1])
{
dlong[i][j] = dlong[i-1][j-1] + 1;
}
else
{
dlong[i][j] = max(dlong[i-1][j],dlong[i][j-1]);
}
}
}
cout<<dlong[strlen(a)][strlen(b)]<<endl;
}
return 0;
}