POJ - 3280  Cheapest Palindrome

 Cheapest Palindrome

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

DP 好难啊。。。。。。。

思路来自:https://blog.csdn.net/zhhx2001/article/details/51656340

给出一个字符串,字符串的长度为m,字符串中不同的字符有n种,并且给出添加或删除每个这n种字符的花费,让你求出让这个字符串成为回文串的最小花费。

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[2010][2010];
int cost[30];
int main()
{
    int n,m,i,j,x,y;
    cin>>n>>m;//m字符串的长度
    string s;
    char c;
    cin>>s;
    for(i=0;i<n;i++)
    {
        cin>>c>>x>>y;
        cost[c-'a']=min(x,y);
    }
    memset(dp,0,sizeof(dp));
    //dp[i][j] 表示 区间[i,j]内的字符串变成回文串 需要的最小花费
    for(int len=0;len<m;len++)
    {
        for(int i=0;i<m;i++)
        {
            int j=i+len;
            if(j>=m) break;
            if(s[i]==s[j])//表示字符串首尾两端已经满足回文条件,只需中间也满足
            {
                dp[i][j]=dp[i+1][j-1];//从外向里 不需要进行添加/删除操作
            }else {
                dp[i][j]=min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j-1]+cost[s[j]-'a']);
             //因为任意回文串在其首尾添加或删除或删除一对相同的字符会构造出新的回文串
             //当i+1到 j是回文串时 dp[i][j]=dp[i+1][j]+min(cost)
             //当i到j-1 是回文串时 dp[i][j]=dp[i][j-1]+min(cost);
            }
        }
    }cout<<dp[0][m-1]<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值