PAT (Advanced Level) Practice 1081 Rational Sum

                                          1081 Rational Sum

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

 AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
struct Fraction{  
    LL  up,down;
};

LL gcd( LL a , LL b )
{
   if( b == 0 ) return a;
   else return gcd( b, a%b );
}
Fraction reduction(Fraction res){
    if(res.down < 0) {
       res.up = -res.up;
       res.down = -res.down;
   }
    if(res.up == 0){
       res.down = 1;
   }else{
     int   d = gcd(abs(res.up),abs(res.down));
     res.up /= d;
     res.down /= d;
    }
  return res;
 }
 
 Fraction add( Fraction f1,Fraction f2){
  Fraction res;
  res.up = f1.up * f2.down+f2.up * f1.down;//分数和的分子
  res.down = f1.down * f2.down;            //分数和的分母
  return reduction(res);
}
void showResult(Fraction r){
   r = reduction(r);
   if(r.down == 1) printf("%lld",r.up);//整数
   else if(abs(r.up) > r.down) printf("%lld %lld/%lld",r.up/r.down,abs(r.up)%r.down,r.down);//假分数
        else printf("%lld/%lld",r.up,r.down); //真分数
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF){
		Fraction sum,temp;
		sum.up=0,sum.down=1;
		for(int i=0;i<n;i++){
			scanf("%lld/%lld",&temp.up,&temp.down);
			sum=add(sum,temp);
		} 
		showResult(sum);
	}
	return 0;
}



结果如下:

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值