hdu-2199-Can you solve this equation

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23135    Accepted Submission(s): 10036


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
 
 
2 100 -4
 

Sample Output
 
 

1.6152 No solution!


题解:这是一道很容易理解的二分题,也很简单,这里需要注意的就是l和r的初始值的问题,这个是自己写代码的习惯问题,反正我一般是r加1,其他的就是while循环里的判断条件,这里的判断条件因为有可能解是小数,所以判断条件是while(r-l>1e-10).

AC代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
double y;
double cal(double x)
{
	return (6 * pow(x, 7) + 8 * pow(x, 6) + 7 * pow(x, 3) + 5 * pow(x, 2) - y*x);
}
void search()
{
	double l, r, mid, rmid;
	l = 0;
	r = 101;
	while (r - l > 1e-10)
	{
		mid = (r + l) / 2;
		rmid = (r + mid) / 2;
		if (cal(mid) < cal(rmid))
		{
			r = rmid;
		}
		else if (cal(mid) > cal(rmid))
		{
			l = mid;
		}
		else
		{
			l = mid;
			r = rmid;
		}
	}
	printf("%.4lf\n", cal(rmid));
	return;
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%lf", &y);
		search();
	}
	return 0;
}

有问题私聊~ 么么哒

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值