2018/8/8

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company. 

There are NN working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into KK new blocks by the following two operations: 

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'. 
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block. 

Now the CEO wants to know the minimum operations to re-arrange current blocks into KKblock with equal size, please help him.

Input

First line contains an integer TT, which indicates the number of test cases. 

Every test case begins with one line which two integers NN and KK, which is the number of old blocks and new blocks. 

The second line contains NN numbers a1a1, a2a2, ⋯⋯, aNaN, indicating the size of current blocks. 

Limits 
1≤T≤1001≤T≤100 
1≤N≤1051≤N≤105 
1≤K≤1051≤K≤105 
1≤ai≤1051≤ai≤105

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations. 

If the CEO can't re-arrange KK new blocks with equal size, y equals -1.

Sample Input

3
1 3
14
3 1
2 3 4
3 6
1 2 3

Sample Output

Case #1: -1
Case #2: 2
Case #3: 3

思维 水题

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<memory.h>
using namespace std;
typedef long long ll;
ll a[100005];

int main()
{
    int T;
    cin>>T;
    int t=0;
    while(T--)
    {
        t++;
        int n,k;
        cin>>n>>k;
        ll sum=0;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
            {
                scanf("%lld",&a[i]);
                sum+=a[i];
            }
        if(sum%k!=0){printf("Case #%d: -1\n",t);continue;}
        ll ave=sum/k;
        ll ans=0;
        ll cnt=0;
        for(int i=0;;i++)
        {
            if(cnt==k)break;
            ll x=a[i];
            if(x%ave==0)
            {
                ans=ans+(x/ave)-1;
                cnt+=x/ave;
                continue;
            }
            while(x>ave)
            {
                x=x-ave;
                ans++;
                cnt++;
            }
            if(x)
            {
                if(a[i+1])
                {
                    a[i+1]+=x;
                    ans++;
                }
                else a[i+1]=x;
            }
        }
        printf("Case #%d: %lld\n",t,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值