[国家集训队]特技飞行 贪心BZOJ2697

[国家集训队]特技飞行 贪心BZOJ2697

题目背景

1.wqs爱好模拟飞行。

2.clj开了一家神犇航空,由于clj还要玩游戏,所以公司的事务由你来打理。

注意:题目中只是用了这样一个背景,并不与真实/模拟飞行相符

题目描述

神犇航空开展了一项载客特技飞行业务。每次飞行长N个单位时间,每个单位时间可以进行一项特技动作,可选的动作有K种,每种动作有一个刺激程度Ci。如果连续进行相同的动作,乘客会感到厌倦,所以定义某次动作的价值为(距上次该动作的时间)*Ci,若为第一次进行该动作,价值为0。安排一种方案,使得总价值最大。

输入输出格式

输入格式:

第一行,两个数,N和K,如上所述;

第二行,K个正整数,表示K种动作的Ci值。

输出格式:

仅一行,一个整数,表示最大总价值。

输入输出样例

输入样例#1: 复制
5 2
2 2
输出样例#1: 复制
12

说明

对于10%的测试数据,N<=20,K<=3

对于全部的测试数据,1<=N<=1000,1<=K<=300,0<=Ci<=1000。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 100005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-4
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {
	ll x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; }


/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
	if (!b) {
		x = 1; y = 0; return a;
	}
	ans = exgcd(b, a%b, x, y);
	ll t = x; x = y; y = t - a / b * y;
	return ans;
}
*/

int n, k;
int c[maxn];
map<int, int>mp;
bool cmp(int x, int y) {
	return x > y;
}
int main() {
	ios::sync_with_stdio(0);
	cin >> n >> k;
	for (int i = 1; i <= k; i++) {
		cin >> c[i];
	}
	sort(c + 1, c + 1 + k, cmp);
	int ans = 0;
	n--; int i = 1;
	while (n > 0 && i <= k) {
		ans += n * (c[i]); n -= 2; i++;
	}
	cout << ans << endl;
	return 0;
}

 

posted @ 2019-01-15 20:51 NKDEWSM 阅读( ...) 评论( ...) 编辑 收藏
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值