A1015 Reversible Primes

A1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目有几个要点:

  • 判断素数的时候考虑n<=1时返回false
  • 注意判断素数条件 i <= (int)sqrt(n * 1.0)
  • 进制转换的时候不要乘错,乘以d 而不是乘以 10
  • 输入终止条件的判断
#include <iostream>
#include <math.h>
using namespace std;
bool isPrime(int n){
  if(n <= 1) return false;
  for(int i = 2; i <= (int)sqrt(n * 1.0); i++){
    if(n % i == 0) return false;
  }
  return true;
}

int tran(int n, int d){       //将n转换成d进制后,翻转后再转为十进制
  int sum = 0;
  string s = "";
  while(n > 0){
    s += to_string(n % d);
    n = n / d;
  }
  for(int i = 0; i < s.length(); i++){
    sum = sum * d + (s[i] - '0');
  }
  return sum;
}

int main(){
  int n,d,m;
  while(scanf("%d", &n) != EOF){
	if(n < 0) break;
	scanf("%d", &d);
	if(!isPrime(n)){
	  cout << "No" << endl;
	  continue;
	}
  m = tran(n, d);
  if(isPrime(m)) 
    cout << "Yes" << endl;
  else
    cout << "No" << endl;
  }
  return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值