哈夫曼译码 swustoj

哈夫曼译码
 1000(ms)
 10000(kb)
 1570 / 3422

通常要求根据给定的编码本对密文进行解码。现已给定相应字符的哈夫曼编码,要求根据编码对密文进行解码。(建立哈夫曼树以及编码、主函数等都已经给出,你只需要填写译码函数void ccode(haffnode  hafftree[],int n)即可。

const int maxvalue=100;

const int maxbit=100;

const int maxn=100;

 #include "iostream"

#include "stdio.h"

#include "stdlib.h"

using namespace std;

struct haffnode

{

 char ch; 

int weight; 

int flag; 

int parent;

 int leftchild; 

int rightchild;

};

struct code

int bit[maxn];

 int start;

 int weight; 

char ch;

}; 

void haffman(int weight[],char text[],int n,haffnode hafftree[])

int j,m1,m2,x1,x2,i; 

for(i=0;i< 2*n-1;i++) 

if(i < n) 

hafftree[i].weight=weight[i]; 

hafftree[i].

ch=text[i];

 } 

else

 { 

hafftree[i].weight=0; 

hafftree[i].ch='#'; 

hafftree[i].parent=0;

 hafftree[i].flag=0;

 hafftree[i].leftchild=-1;

 hafftree[i].rightchild=-1;

 } 

for(i=0;i< n-1;i++) 

m1=m2=maxvalue;

 x1=x2=0; 

for(j=0;j< n+i;j++) 

if(hafftree[j].weight< m1&&hafftree[j].flag==0) 

m2=m1;

 x2=x1;

 m1=hafftree[j].weight;

 x1=j; 

else if(hafftree[j].weight< m2&&hafftree[j].flag==0)

 { 

m2=hafftree[j].weight; x2=j;

 } 

hafftree[x1].parent=n+i; 

hafftree[x2].parent=n+i;

 hafftree[x1].flag=1; 

hafftree[x2].flag=1; 

hafftree[n+i].weight=hafftree[x1].weight+hafftree[x2].weight; 

hafftree[n+i].leftchild=x1; hafftree[n+i].rightchild=x2;

 } 

void haffmancode(haffnode hafftree[],int n,code haffcode[])

code cd; int i,j; int child,parent;

 for( i=0;i< n;i++)

 { 

cd.start=n-1; 

cd.weight=hafftree[i].weight; 

cd.ch=hafftree[i].ch; 

child=i; 

parent=hafftree[child].parent; 

while(parent!=0)

 { 

if(hafftree[parent].leftchild==child) 

cd.bit[cd.start]=0; 

else cd.bit[cd.start]=1; 

cd.start--; 

child=parent; 

parent=hafftree[child].parent; 

for(j=cd.start+1;j< n;j++) 

haffcode[i].bit[j]=cd.bit[j];

 haffcode[i].start=cd.start;

 haffcode[i].weight=cd.weight; 

haffcode[i].ch=cd.ch;

 } 

void ccode(haffnode hafftree[],int n)

{ }

 int main( )

int n=8; 

int weight[]={5,29,7,8,14,23,3,11};

 char text[]={'a','b','c','d','e','f','g','h'}; 

haffnode myhafftree[maxvalue]; 

code myhaffcode[maxvalue];

 haffman(weight,text,n,myhafftree);

 haffmancode(myhafftree,n,myhaffcode); 

ccode(myhafftree,n); 

return 0;

}

输入
 
  

根据哈夫曼树编码表,针对字符串做好的编码结果。

输出
 
  

对每一行需要解码的串,进行解码,并输出解码后的结果。

样例输入
000100011011101110
样例输出
aabcc

就是把他给的代码瞎改就a了;

const int maxvalue=100;
const int maxbit=100;
const int maxn=100;
#include "iostream"
#include "stdio.h"
#include "string.h"
#include "stdlib.h"
using namespace std;
struct haffnode
{
  char ch; 
int weight; 
int flag; 
int parent;
  int leftchild; 
int rightchild;
};
struct code

int bit[maxn];
int start;
int weight; 
char ch;
}; 
void haffman(int weight[],char text[],int n,haffnode hafftree[])

int j,m1,m2,x1,x2,i; 
for(i=0;i< 2*n-1;i++) 

if(i < n) 

hafftree[i].weight=weight[i]; 
hafftree[i].ch=text[i];

else
 
hafftree[i].weight=0; 
hafftree[i].ch='#'; 

hafftree[i].parent=0;
hafftree[i].flag=0;
hafftree[i].leftchild=-1;
hafftree[i].rightchild=-1;

for(i=0;i< n-1;i++) 

m1=m2=maxvalue;
x1=x2=0; 
for(j=0;j<n+i;j++) 

if(hafftree[j].weight<m1&&hafftree[j].flag==0) 

m2=m1;
x2=x1;
m1=hafftree[j].weight;
  x1=j; 

else if(hafftree[j].weight< m2&&hafftree[j].flag==0)
 
m2=hafftree[j].weight; x2=j;
 

hafftree[x1].parent=n+i; 
hafftree[x2].parent=n+i;
  hafftree[x1].flag=1; 
hafftree[x2].flag=1; 
hafftree[n+i].weight=hafftree[x1].weight+hafftree[x2].weight; 
hafftree[n+i].leftchild=x1; hafftree[n+i].rightchild=x2;
 

void haffmancode(haffnode hafftree[],int n,code haffcode[])

code cd; int i,j; int child,parent;
  for( i=0;i< n;i++)
 
cd.start=n-1; 
cd.weight=hafftree[i].weight; 
cd.ch=hafftree[i].ch; 
child=i; 
parent=hafftree[child].parent; 
while(parent!=0)
 
if(hafftree[parent].leftchild==child) 
cd.bit[cd.start]=0; 
else cd.bit[cd.start]=1; 
cd.start--; 
child=parent; 
parent=hafftree[child].parent; 

for(j=cd.start+1;j<n;j++) 
haffcode[i].bit[j]=cd.bit[j];
  haffcode[i].start=cd.start;
  haffcode[i].weight=cd.weight; 
haffcode[i].ch=cd.ch;
 

void ccode(haffnode hafftree[],int n)
{
int i,j=0,m=2*n-1;
    char b[maxn];
    memset(b,'\0',sizeof(b));
    i=m-1;                      
    scanf("%s",b);
    while(b[j]!='\0')
    {
        if(b[j]=='0')
            i=hafftree[i].leftchild;              
        else
            i=hafftree[i].rightchild;              
        if(hafftree[i].leftchild==-1)         
        {
            printf("%c",hafftree[i].ch);
            i=m-1;      
        }
        j++;
    }
}
int main( )

int n=8; 
int weight[]={5,29,7,8,14,23,3,11};
char text[]={'a','b','c','d','e','f','g','h'}; 
haffnode myhafftree[maxvalue]; 
code myhaffcode[maxvalue]; 
haffman(weight,text,n,myhafftree);
haffmancode(myhafftree,n,myhaffcode); 
ccode(myhafftree,n); 
return 0;
}

  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值