ZOJ3911 Prime Query线段树

链接
Prime Query
Time Limit: 5 Seconds Memory Limit: 196608 KB
You are given a simple task. Given a sequence A[i] with N numbers. You have to perform Q operations on the given sequence.

Here are the operations:

A v l, add the value v to element with index l.(1<=V<=1000)
R a l r, replace all the elements of sequence with index i(l<=i<= r) with a(1<=a<=10^6) .
Q l r, print the number of elements with index i(l<=i<=r) and A[i] is a prime number
Note that no number in sequence ever will exceed 10^7.

Input
The first line is a signer integer T which is the number of test cases.

For each test case, The first line contains two numbers N and Q (1 <= N, Q <= 100000) - the number of elements in sequence and the number of queries.

The second line contains N numbers - the elements of the sequence.

In next Q lines, each line contains an operation to be performed on the sequence.

Output
For each test case and each query,print the answer in one line.

Sample Input
1
5 10
1 2 3 4 5
A 3 1
Q 1 3
R 5 2 4
A 1 1
Q 1 1
Q 1 2
Q 1 4
A 3 5
Q 5 5
Q 1 5
Sample Output
2
1
2
4
0
4
线段树入门题 涉及到区间修改 单点更新

#include <stdio.h>
#include <string.h>
const int maxn = 1e5+10;
const int maxsize = 1e7+1024;
struct ST
{
    int l,r;
    int sum;
    int add;//值
    int lazy;
} t[maxn*4];
int prime[maxsize];
int a;
void get()//打一个素数表
{
    memset(prime,0,sizeof(prime));
    prime[0] = prime[1] = 1;
    for(int i = 2; i < 3200; i++)
    {
        if(!prime[i])
        {
            for(int j = i*i; j < maxsize; j += i)
            {
                prime[j] = 1;   //0为素数
            }
        }
    }
}
void push_up(int p)
{
    t[p].sum = t[p<<1].sum+t[p<<1|1].sum;
}
/*向下打标记*/
void push_down(int p)
{
    if(t[p].lazy)
    {
        int tmp = (!prime[t[p].add])?1:0;
        t[p<<1].sum = tmp*(t[p<<1].r-t[p<<1].l+1);
        t[p<<1|1].sum = tmp*(t[p<<1|1].r-t[p<<1|1].l+1);
        t[p<<1|1].lazy = t[p<<1].lazy = t[p].lazy;
        t[p<<1].add = t[p].add;
        t[p<<1|1].add = t[p].add;
        t[p].lazy = 0;//最开始这里写成了t[p].add = 0; 而 t[p].add 会影响后面的值
    }
}
void build(int p,int l,int r)
{
    t[p].l = l;
    t[p].r = r;
    t[p].lazy = 0;
    if(l == r)
    {
        scanf("%d",&a);
        t[p].add = a;
        t[p].sum = (!prime[a])?1:0;
        return ;
    }
    int mid = (l+r)>>1;
    build(p<<1,l,mid);
    build(p<<1|1,mid+1,r);
    push_up(p);
}
void updata1(int p,int l,int r,int v)//区间更新
{
    if(l == t[p].l && r == t[p].r)
    {
        t[p].lazy = t[p].add = v;
        int tmp = (!prime[v])?1:0;
        t[p].sum = tmp*(t[p].r-t[p].l+1);
        return ;
    }
    push_down(p);
    int mid = (t[p].l+t[p].r)>>1;
    if(l > mid)
      updata1(p<<1|1,l,r,v);
    else if(r <= mid)
        updata1(p<<1,l,r,v);
    else
       {updata1(p<<1|1,mid+1,r,v);updata1(p<<1,l,mid,v);}
    push_up(p);
}
void updata(int p,int x,int v)//单点修改
{
    if(t[p].l == t[p].r)
    {
        t[p].add += v;
        t[p].sum = (!prime[t[p].add])?1:0;
        return ;
    }
    push_down(p);
    int mid = (t[p].l + t[p].r) >> 1;
    if(x <= mid)
        updata(p<<1,x,v);
    else
        updata(p<<1|1,x,v);
    push_up(p);
}
int ask(int p,int l,int r)
{
    if(l <= t[p].l && r >= t[p].r)
        return t[p].sum;
    push_down(p);
    int mid = (t[p].l+t[p].r)>>1;
    int val = 0;
    if(l <= mid)
        val += ask(p<<1,l,r);
    if(r > mid)
        val += ask(p<<1|1,l,r);
    /*if(l > mid)
        val += ask(p<<1|1,l,r);
    else if(r <= mid)
        val += ask(p<<1,l,r);
    else
        val = val + ask(p<<1|1,mid+1,r)+ask(p<<1,l,mid);*/
    return val;
}
void debug(int p,int l,int r)
{
    if(l == r)
    {
        printf("%d %d\n",t[p].add,t[p].sum);
        return ;
    }
    int mid = (l+r)>>1;
    if(l <= mid)
        debug(p<<1,l,mid);
    if(r > mid)
        debug(p<<1|1,mid+1,r);
}
int main()
{
    get();
    int t;
    scanf("%d",&t);
    char str[2];
    int v,l,r;
    while(t--)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        build(1,1,n);
      //  debug(1,1,n);
   //  puts("");
        while(k--)
        {
            scanf("%s",str);
            if(str[0] == 'A')
            {
                scanf("%d%d",&v,&l);
                updata(1,l,v);
            }
            else if(str[0] == 'Q')
            {
                scanf("%d%d",&l,&r);
                printf("%d\n",ask(1,l,r));
            }
            else
            {
                scanf("%d%d%d",&v,&l,&r);
                updata1(1,l,r,v);
            }
           //    debug(1,1,n);
           // puts("");
        }
    }
    return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
水资源是人类社会的宝贵财富,在生活、工农业生产中是不可缺少的。随着世界人口的增长及工农业生产的发展,需水量也在日益增长,水已经变得比以往任何时候都要珍贵。但是,由于人类的生产和生活,导致水体的污染,水质恶化,使有限的水资源更加紧张。长期以来,油类物质(石油类物质和动植物油)一直是水和土壤中的重要污染源。它不仅对人的身体健康带来极大危害,而且使水质恶化,严重破坏水体生态平衡。因此各国都加强了油类物质对水体和土壤的污染的治理。对于水中油含量的检测,我国处于落后阶段,与国际先进水平存在差距,所以难以满足当今技术水平的要求。为了取得具有代表性的正确数据,使分析数据具有与现代测试技术水平相应的准确性和先进性,不断提高分析成果的可比性和应用效果,检测的方法和仪器是非常重要的。只有保证了这两方面才能保证快速和准确地测量出水中油类污染物含量,以达到保护和治理水污染的目的。开展水中油污染检测方法、技术和检测设备的研究,是提高水污染检测的一条重要措施。通过本课题的研究,探索出一套适合我国国情的水质污染现场检测技术和检测设备,具有广泛的应用前景和科学研究价值。 本课题针对我国水体的油污染,探索一套检测油污染的可行方案和方法,利用非分散红外光度法技术,开发研制具有自主知识产权的适合国情的适于野外便携式的测油仪。利用此仪器,可以检测出被测水样中亚甲基、甲基物质和动植物油脂的污染物含量,为我国众多的环境检测站点监测水体的油污染状况提供依据。
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值