ospf跨区域+mgre+重发布

将eigrp重发布到ospf中,在area 2中重发布的路由以7类lsa传输

area4 与area0 之间使用 tunnel 或 虚链路逻辑相连(这用的是tunnel)

R3--R5/6/7为 mgre 环境 R3为中心站点(应注意更改tunnel接口的网络类型,默认点到点)

 

R1:

hostname R1

interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 1 stub no-summary
 network 172.16.0.0 0.0.0.7 area 1
 network 172.16.1.0 0.0.0.255 area 1
!

R2与R1大致相同

R3:

!
hostname R3
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!
interface Tunnel0
 ip address 172.16.0.33 255.255.255.248
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip ospf network broadcast
 ip ospf priority 255
 tunnel source Serial2/0
 tunnel mode gre multipoint
!
interface FastEthernet0/0
 ip address 172.16.0.3 255.255.255.248
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto

interface Serial2/0
 ip address 34.0.0.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 area 1 stub no-summary
 network 172.16.0.0 0.0.0.7 area 1
 network 172.16.0.32 0.0.0.7 area 0
 network 172.16.3.0 0.0.0.255 area 1
 default-information originate always
!
ip route 0.0.0.0 0.0.0.0 Serial2/0

!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit any

R4:

hostname R4
interface Serial2/0
 ip address 34.0.0.2 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 ip address 45.0.0.1 255.255.255.0
 serial restart-delay 0
!         
interface Serial2/2
 ip address 46.0.0.1 255.255.255.0
 serial restart-delay 0
!
interface Serial2/3
 ip address 47.0.0.1 255.255.255.0
 serial restart-delay 0
interface Loopback0
 ip address 4.4.4.4 255.255.255.0

R5:

hostname R5
!
interface Loopback0
 ip address 172.16.5.1 255.255.255.0
!
interface Tunnel0
 ip address 172.16.0.34 255.255.255.248
 no ip redirects
 ip nhrp map 172.16.0.33 34.0.0.1
 ip nhrp map multicast 45.0.0.1
 ip nhrp map multicast 172.16.0.33
 ip nhrp map multicast 34.0.0.1
 ip nhrp network-id 100
 ip nhrp nhs 172.16.0.33
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source Serial2/0
 tunnel mode gre multipoint
!
interface Serial2/0
 ip address 45.0.0.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 172.16.0.32 0.0.0.7 area 0
 network 172.16.5.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial2/0
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Serial2/0 overload

R6:

hostname R6
!
interface Loopback0
 ip address 172.16.6.1 255.255.255.0
!
interface Tunnel0
 ip address 172.16.0.35 255.255.255.248
 no ip redirects
 ip nhrp map 172.16.0.33 34.0.0.1
 ip nhrp map multicast 45.0.0.1
 ip nhrp map multicast 172.16.0.33
 ip nhrp map multicast 34.0.0.1
 ip nhrp network-id 100
 ip nhrp nhs 172.16.0.33
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source Serial2/0
 tunnel mode gre multipoint
!
interface Serial2/0
 ip address 46.0.0.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 ip address 172.16.0.22 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 ip ospf 1 area 3
 serial restart-delay 0
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 3 nssa no-summary
 network 172.16.0.32 0.0.0.7 area 0
 network 172.16.6.0 0.0.0.255 area 0
 default-information originate always
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial2/0
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit any

R7:

hostname R7
interface Loopback0
 ip address 172.16.7.1 255.255.255.0
!
interface Tunnel0
 ip address 172.16.0.36 255.255.255.248
 no ip redirects
 ip nhrp map 172.16.0.33 34.0.0.1
 ip nhrp map multicast 45.0.0.1
 ip nhrp map multicast 172.16.0.33
 ip nhrp map multicast 34.0.0.1
 ip nhrp network-id 100
 ip nhrp nhs 172.16.0.33
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source Serial2/0
 tunnel mode gre multipoint
!
!
interface Tunnel1
 ip address 172.16.0.30 255.255.255.252
 ip ospf 1 area 4
 tunnel source Serial2/1
 tunnel destination 172.16.0.14
interface Serial2/0
 ip address 47.0.0.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 ip address 172.16.0.9 255.255.255.252
 ip nat inside
 ip virtual-reassembly
 ip ospf 1 area 2
 serial restart-delay 0
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 area 2 stub no-summary
 area 3 stub
 area 4 stub no-summary
 network 172.16.0.32 0.0.0.7 area 0
 network 172.16.7.0 0.0.0.255 area 0
 default-information originate always

ip route 0.0.0.0 0.0.0.0 Serial2/0
!
!
ip nat inside source list 1 interface Serial2/0 overload
access-list 1 permit any

R8:

hostname R8
interface Loopback0
 ip address 172.16.8.1 255.255.255.0
 ip ospf 1 area 2
interface Serial2/0
 ip address 172.16.0.10 255.255.255.252
 ip ospf 1 area 2
 serial restart-delay 0
!
interface Serial2/1
 ip address 172.16.0.13 255.255.255.252
 ip ospf 1 area 2
 serial restart-delay 0
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 area 2 stub no-summary

R9:

hostname R9
interface Loopback0
 ip address 172.16.9.1 255.255.255.0
 ip ospf 1 area 4
!
interface Tunnel0
 ip address 172.16.0.29 255.255.255.252
 ip ospf 1 area 4
 tunnel source Serial2/0
 tunnel destination 172.16.0.9
interface Serial2/0
 ip address 172.16.0.14 255.255.255.252
 ip ospf 1 area 2
 serial restart-delay 0
!
interface Serial2/1
 ip address 172.16.0.17 255.255.255.252
 ip ospf 1 area 4
 serial restart-delay 0

router ospf 1
 router-id 9.9.9.9
 log-adjacency-changes
 area 2 stub no-summary
 area 4 stub

R10:

hostname R10
interface Loopback0
 ip address 172.16.10.1 255.255.255.0
!
interface Serial2/0
 ip address 172.16.0.18 255.255.255.252
 serial restart-delay 0
router ospf 1
 log-adjacency-changes
 area 4 stub no-summary
 network 0.0.0.0 255.255.255.255 area 4

R11:

hostname R11
interface Loopback0
 ip address 172.16.11.1 255.255.255.0
interface Serial2/0
 ip address 172.16.0.21 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 172.16.0.25 255.255.255.252
 serial restart-delay 0
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 area 3 nssa no-summary
 network 0.0.0.0 255.255.255.255 area 3

R12

hostname R12
interface Loopback0
 ip address 172.16.12.1 255.255.255.128
!
interface Loopback1
 ip address 172.16.12.129 255.255.255.128
!
interface Serial2/0
 ip address 172.16.0.26 255.255.255.252
 ip ospf 1 area 3
 serial restart-delay 0
router eigrp 90
 network 172.16.12.0 0.0.0.255
 no auto-summary
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 area 3 nssa no-summary
 redistribute eigrp 90 subnets
!         

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值