C/C++训练1---最大公约数与最小公倍数(类)

Problem Description

输入两个正整数,求它们的最大公约数与最小公倍数。

Input

输入两个正整数,两个整数之间用空格分开。

数据保证在 int 范围内。

Output

第一行输出最大公约数;
第二行输出最小公倍数。

答案保证在 int 范围内。

Sample Input
64 48
Sample Output
16
192

import java.util.Scanner; 
class gongyue {
	int x, y;
	public gongyue(int x, int y){
		this.x = x;
		this.y = y;
	}
	public int gy(){
		if(x>y){
			int t=x;x=y;y=t;
		}
		while(x!=0){
			int t = y%x;
			y = x;
			x = t;
		}
		return y;
	}
}

class gongbei {
	int x, y;
	public gongbei(int x, int y){
		this.x = x;
		this.y = y;
	}
	public int gb(){
		int a=x, b=y;  
		gongyue rect = new gongyue(a, b);
        int g =  rect.gy();
        return x*y/g;  
	}
}
public class Main {

	public static void main(String[] args) {  
        Scanner reader = new Scanner(System.in);  
        int x = reader.nextInt();  
        int y = reader.nextInt();  
        gongyue m = new gongyue(x, y);
        gongbei n = new gongbei(x, y);
        int a = m.gy();
        int b = n.gb();
        System.out.println(a+"\n"+b);
    }     

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值