C/C++经典程序训练3---模拟计算器(类)

Problem Description

简单计算器模拟:输入两个整数和一个运算符,输出运算结果。

Input

第一行输入两个整数,用空格分开;
第二行输入一个运算符(+、-、*、/)。
所有运算均为整数运算,保证除数不包含0。

Output

输出对两个数运算后的结果。

Sample Input
30 50
*
Sample Output
1500


import java.util.Scanner; 
class compute {
	int a, b;
	char c;
	public compute(int a, int b, char c) {
		this.a = a;
		this.b = b;
		this.c = c;
	}
	public int jisuan(){
		if(c=='+'){
			return a+b;
		}
		else if(c=='-'){
			return a-b;
		}
		else if(c=='*'){
			return a*b;
		}
		else if(c=='/'){
			return a/b;
		}
		else{
			return 0;
		}
	}
	
}
public class Main {  
  
    public static void main(String[] args) {    
        Scanner reader = new Scanner(System.in);    
        int a = reader.nextInt();    
        int b = reader.nextInt();
        
        String s = reader.nextLine();
        s = reader.nextLine();
        char c = s.charAt(0);
        compute rect = new compute(a,b,c);
        int sum = rect.jisuan();
        System.out.println(sum);  
    }       
  
}  

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值