求绝对值最大值

Problem Description
求n个整数中的绝对值最大的数。
Input
输入数据有2行,第一行为n,第二行是n个整数。
Output
输出n个整数中绝对值最大的数。
Sample Input
5
-1 2 3 4 -5
Sample Output
-5

import java.util.Scanner;   
public class Main {    
    
    public static void main(String[] args) {      
        Scanner reader = new Scanner(System.in); 
        int[] a = new int[100];
        int n = reader.nextInt();
        for(int i=0; i<n; i++) {
        	a[i] = reader.nextInt();
        }
        int max=0 , k=0;
        for(int i=0; i<n; i++) {
        	if(Math.abs(a[i])>=max) {
        		max = Math.abs(a[i]);
        		k=i;
        	}
        }
        System.out.println(a[k]);
    }         
}    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值