活动选择

Problem Description

学校的大学生艺术中心周日将面向全校各个学院的学生社团开放,但活动中心同时只能供一个社团活动使用,并且每一个社团活动开始后都不能中断。现在各个社团都提交了他们使用该中心的活动计划(即活动的开始时刻和截止时刻)。请设计一个算法来找到一个最佳的分配序列,以能够在大学生艺术中心安排不冲突的尽可能多的社团活动。
比如有5个活动,开始与截止时刻分别为:



最佳安排序列为:1,4,5。

Input

第一行输入活动数目n(0<n<100);
以后输入n行,分别输入序号为1到n的活动使用中心的开始时刻a与截止时刻b(a,b为整数且0<=a,b<24,a,b输入以空格分隔)。

Output

输出最佳安排序列所包含的各个活动(按照活动被安排的次序,两个活动之间用逗号分隔)。

Sample Input

6
8 10
9 16
11 16
14 15
10 14
7 11

Sample Output

1,5,4
#include <bits/stdc++.h>
using namespace std;

struct node{
    int start;
    int end;
    int id;
};

bool cmp(node a, node b){
    return a.end<b.end;
}

int main(){
    int n, table[110], cnt=0;
    int flag;
    node list[110];
    cin>>n;
    for(int i=0; i<n; i++){
        cin>>list[i].start>>list[i].end;
        list[i].id = i+1;
    }

    sort(list, list+n, cmp);
    table[cnt++] = list[0].id;

    for(int i=0; i<n; i++){
        if(list[i].start>=list[flag].end){
            table[cnt++] = list[i].id;
            flag = i;
        }
    }
    for(int i=0; i<cnt; i++){
        if(i<cnt-1){
            cout<<table[i]<<',';
        }
        else{
            cout<<table[i]<<endl;
        }
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值