Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
#include<iostream>
#include<fstream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<cmath>
#include<cctype>
using namespace std;
#define PI acos(-1.0)
//#define mp make_pair
#define fi first
#define se second
#define pb push_back
#define forn(i,n) for(int i=0;i<n;i++)
#define for1(i,n) for(int i=1;i<=n;i++)
#define rep(i,a,n) for(int i=a;i<n;i++)
#define IO \
ios::sync_with_stdio(false); \
cin.tie(0);
typedef long long ll;
typedef pair<int,int> pii;
typedef pair<ll,ll> pll;
const int INF32M=0x3f3f3f3f;
const ll INF64M=0x3f3f3f3f3f3f3f3f;
const int maxn=1e5+5;
const int mod=1e9+7;
int gcd(int a,int b)
{
return b!=0?gcd(b,a%b):a;
}
int pre[1005];
int find(int x)
{
if(pre[x]==x)
return x;
return find(pre[x]);
}
/*void union(int x,int y)
{
int rx=find(x);
int ry=find(y);
if(rx!=ry)
pre[rx]=ry;
}*/
int main()
{
int n,m;
while(cin>>n && n)
{
int num=0;
cin>>m;
for(int i=1;i<=n;i++)
pre[i]=i;
int a,b;
for(int i=1;i<=m;i++)
{
cin>>a>>b;
int rx=find(a);
int ry=find(b);
if(rx!=ry)
{
pre[rx]=ry;
num++;
}
}
printf("%d\n",n-1-num);
}
return 0;
}