CodeForces - 1029A Many Equal Substrings

原题目链接CodeForces - 1029A


分类

CodeForces KMP


题意

这题是给一个长度为n的字符串 要拼成一个新串使得原来的串在新串中出现k次,用kmp预处理一下首尾的相同前后缀长度,然后就行了

Sample Input

3 4
aba
3 2
cat

Sample Output

ababababa
catcat

代码

31ms

/**
 * Author: GatesMa
 * Email: gatesma@foxmail.com
 * Todo: ACM Training
 * Date:2018/11/4
 */
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn = 111;

char s[maxn];
int next[maxn];
void getNext()
{
    int len = strlen(s);
    int j = 0, k = -1;
    next[0] = -1;
    while (j < len)
    {
        if (k == -1 || s[j] == s[k])
        {
            j++;
            k++;
            next[j] = k;
        }
        else
        {
            k = next[k];
        }
    }
}
int main()
{
    int n, k;
    scanf("%d %d", &n, &k);
    scanf("%s", s);
    getNext();
    int cnt = next[n];
    if (cnt == 0)
    {
        for (int i = 0; i < k; i++)
        {
            printf("%s", s);
        }
        printf("\n");
    }
    else
    {
        printf("%s", s);
        for (int i = 0; i < k - 1; i++)
        {
            printf("%s", s + cnt);
        }
        printf("\n");
    }
    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值