HDU1213 How Many Tables 并查集

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

#include<bits/stdc++.h>
using namespace std;
const int maxn=1050;
int T,N,M,a,b,f[maxn];

void init_set(){                                 //初始化
    for(int i=1;i<maxn;i++)   f[i]=i;
}

int find_set(int x){                            //查找
    return f[x]==x ? x: find_set(f[x]);
}

void union_set(int a,int b){                //合并
    a=find_set(a);
    b=find_set(b);
    if(a!=b)    f[a]=f[b];
}

int main(){
    ios::sync_with_stdio(false);
    cin.tie(0),cout.tie(0);

    cin>>T;
    while(T--){
        cin>>N>>M;
        init_set();
        for(int i=0;i<M;i++){
            cin>>a>>b;
            union_set(a,b);
        }
        int ans=0;
        for(int i=1;i<=N;i++)
            if(f[i]==i) ans++;
        cout<<ans<<endl;
    }
    return 0;
}

合并的优化

void init_set(){                                 //初始化
    for(int i=1;i<maxn;i++)   {
        f[i]=i;
        height[i]=0;
    }
}
void union_set(int a,int b){                //合并
    a=find_set(a);
    b=find_set(b);
    if(height[a]==height[b]){
        height[a]++;
        f[b]=a;
    }else{
        if(height[a]<height[b]) f[a]=b;
        else    f[b]=a;
    }
}

查询优化——路径压缩

int find_set(int x){                           //路径压缩
    if(x!=f[x]) f[x]=find_set(f[x]);
    return f[x];
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jaggar_F

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值