Sorting Slides(二分最大匹配+关键边)

Sorting Slides

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5070 Accepted: 1983

Description

Professor Clumsey is going to give an important talk this afternoon. Unfortunately, he is not a very tidy person and has put all his transparencies on one big heap. Before giving the talk, he has to sort the slides. Being a kind of minimalist, he wants to do this with the minimum amount of work possible. 

The situation is like this. The slides all have numbers written on them according to their order in the talk. Since the slides lie on each other and are transparent, one cannot see on which slide each number is written. 


Well, one cannot see on which slide a number is written, but one may deduce which numbers are written on which slides. If we label the slides which characters A, B, C, ... as in the figure above, it is obvious that D has number 3, B has number 1, C number 2 and A number 4. 

Your task, should you choose to accept it, is to write a program that automates this process.

Input

The input consists of several heap descriptions. Each heap descriptions starts with a line containing a single integer n, the number of slides in the heap. The following n lines contain four integers xmin, xmax, ymin and ymax, each, the bounding coordinates of the slides. The slides will be labeled as A, B, C, ... in the order of the input. 

This is followed by n lines containing two integers each, the x- and y-coordinates of the n numbers printed on the slides. The first coordinate pair will be for number 1, the next pair for 2, etc. No number will lie on a slide boundary. 

The input is terminated by a heap description starting with n = 0, which should not be processed. 

Output

For each heap description in the input first output its number. Then print a series of all the slides whose numbers can be uniquely determined from the input. Order the pairs by their letter identifier. 

If no matchings can be determined from the input, just print the word none on a line by itself. 

Output a blank line after each test case. 

Sample Input

4
6 22 10 20
4 18 6 16
8 20 2 18
10 24 4 8
9 15
19 17
11 7
21 11
2
0 2 0 2
0 2 0 2
1 1
1 1
0

Sample Output

Heap 1
(A,4) (B,1) (C,2) (D,3)

Heap 2
none

Source

Southwestern European Regional Contest 1998

 

这道题的题意是,在已知的方框中确定哪个数字是属于那个框的,然后匹配出来,否则就输出none。关键边是除去一条边之后图相比之前来说不连通了,这条边就是关键边,(emmm,其实就是最大匹配数少了)我们建图之后找出所有的关键边,再输出答案。emmm,找关键边的方法是,先删除一条边,如果这样的情况下,最大匹配边没有变的话,他就不是关键边,,同理如果少了,他就是关键边,另外注意下格式,,,

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=1010;
int e[N][N];
int match[N];
int book[N];
int n,xmin[N],xmax[N],ymin[N],ymax[N],x[N],y[N];
int dfs(int u)
{
    int i;
    for(i=1; i<=n; i++)
    {
        if(book[i]==0&&e[u][i]==1)
        {
            book[i]=1;
            if(match[i]==0||dfs(match[i]))
            {
                match[i]=u;
//                match[u]=i;
                return 1;
            }
        }
    }
    return 0;
}
int ff()
{
    for(int i=1; i<=n; i++) match[i]=0;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++) book[j]=0;
        if(!dfs(i)) return 0;
    }
    return 1;
}
int main()
{
    int hhh=1;
    while(~scanf("%d",&n)&&n)
    {
        memset(e,0,sizeof(e));
        for(int i=1; i<=n; i++)
            scanf("%d%d%d%d",&xmin[i],&xmax[i],&ymin[i],&ymax[i]);
        for(int i=1; i<=n; i++)
            scanf("%d%d",&x[i],&y[i]);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(x[j]>=xmin[i]&&x[j]<=xmax[i]&&y[j]<=ymax[i]&&y[j]>=ymin[i])
                {
                    e[i][j]=1;
                }
            }
        }
        printf("Heap %d\n",hhh++);
        int flag=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(!e[i][j]) continue;
                e[i][j]=0;
                if(!ff())/*如果是必须边*/
                {
                    if(!flag)
                    {
                        printf("(%c,%d)",i-1+'A',j);
                        flag=1;
                    }
                    else
                        printf(" (%c,%d)",i-1+'A',j);
                }
                e[i][j]=1;
            }
        }
        if(!flag)
            printf("none");
        printf("\n\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值