异或运算的牛逼

//我擦抑或这么牛。
/*
 *异或运算在
    进行0和任何数异或还是原数。
    异或两次后可以相当于没有算那个数。
 */
#include<stdio.h>
int main()
{
    int n;
    scanf("%d",&n);
    while (n){
        int result = 0;
        while (n --){
            int a;
            scanf("%d",&a);
            result ^= a;
        }
        printf("%d\n",result);
        scanf("%d",&n);
    }
    return 0;
}
find your present (2)——中级
Time Limit: 1000MS Memory Limit: 1000K
Total Submissions: 244 Accepted: 107

Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 231. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5
1 1 3 2 2
3
1 2 1
0

Sample Output

3
2

Hint

use scanf to avoid Time Limit Exceeded

另外,我原来的算法还是有点问题的。

#include<stdio.h>

void sort(int *a,int left,int right){
    if (left >= right)return ;
    int i = left;
    int j = right;
    int key = a[left];
    while (i < j){
        while (i < j&&key <= a[j]){
            j --;
        }
        a[i] = a[j];
        while (i < j&&key >= a[i]){
            i ++;
        }
        a[j] = a[i];
    }
    a[i] = key;
    sort(a,left,i-1);
    sort(a,i+1,right);
}

int a[1000000];

int main()
{
    int n;

    while (scanf("%d",&n)&&n){
        if (n == 0)break;
        int i;
        for (i = 0;i < n;i ++)
            scanf("%d",&a[i]);
        sort(a,0,n-1);
        if (n == 1){printf("%d\n",a[0]);continue;}
        else if (a[0]!=a[1]){printf("%d\n",a[0]);continue;}
        else if (a[n-1]!=a[n-2]){printf("%d\n",a[n-1]);continue;}
        else {
            for (i = 1;i < n-1;i ++)
                if (a[i]!=a[i-1]&&a[i]!=a[i+1]){
                        printf("%d\n",a[i]);
                        break;
                }
        }
    }
    return 0;
}


像这个,我用了C++中的sort都不行。

如果数组开小了一点就会出现runtime error


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值