Basically Speaking 转换进制 C语言 itoa strtol Java语言 Integer.valueOf Integer.toString

Basically Speaking

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4163    Accepted Submission(s): 1691


 

Problem Description

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features: 
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16. 

 

 

Input

The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.

 

 

Output

The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display. 

 

 

Sample Input

 

1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15

 

 

Sample Output

 

120 78 1765 7CA ERROR 11001 12D687 D071

 

 

Source

Mid-Central USA 1995

 

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1346 1338 1347 1333 1336 

 

 

 

C++ AC代码

#include<cstdio>
#include<cstring>
 #include <cstdlib>
int main()
{
    char num[8];
    int oldC;
    int newC;
    while(scanf("%s %d %d",num,&oldC,&newC)!=EOF){
        char *stop;
        int ans=strtol(num, &stop,oldC);//转换成10进制
        char str[100];
        itoa(ans,str,newC);
        if(strlen(str)>7){
            printf("  ERROR\n");
            continue;
        }
        for(int i=0;i<strlen(str);i++){
            if(str[i]>='a' && str[i]<='z'){
                str[i]=str[i]-'a'+'A';
            }
        }
        int j=0;
        for(int i=0;i<7-strlen(str);i++)printf(" ");
        printf("%s\n",str);
        
    }
    return 0;
}
 

 

JAVA 

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            String strNum = sc.next();
            int a = sc.nextInt();
            int b = sc.nextInt();

            int s = Integer.valueOf(strNum, a);
            //将a进制的strNum转换成10进制s
            String sNum = Integer.toString(s, b);

            if(sNum.length()>7){
                System.out.println("  ERROR");
                continue;
            }

            for(int i=7;i>sNum.length();i--){
                System.out.print(" ");
            }
            System.out.println(sNum.toUpperCase());

        }

    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值