PAT甲级1003

1003 Emergency (25point(s))

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题目大意:救援队从起点出发,每经过一个城市,召集这个城市的人手,求到终点的最短路径条数及在最短的路径下能召集到的最多人手。
解题思路:很明显这道题使用Dijkstra算法就可以,在此基础上加入了第二标尺(点权),和第三标尺(最短路径条数),如果你有《算法笔记》这本书的话,可直接参考376-378页。

Java代码:

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	static int n, m, st, ed;
	static int[] weight, dis, num, we;
	static boolean[] visited;
	static int[][] G;
	static int INF = 999999999;
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		n = sc.nextInt();
		m = sc.nextInt();
		st = sc.nextInt();
		ed = sc.nextInt();
		weight = new int[n];
		we = new int[n];
		dis = new int[n];
		num = new int[n];
		visited = new boolean[n];
		G = new int[n][n];
		for (int i = 0; i < n; i++) {
			weight[i] = sc.nextInt();
			Arrays.fill(G[i], INF);
		}
		for (int i = 0; i < m; i++) {
			int a = sc.nextInt();
			int b = sc.nextInt();
			G[a][b] = sc.nextInt();
			G[b][a] = G[a][b];
		}
		Dijkstra(st);
		System.out.println(num[ed] + " " + we[ed]);
	}

	static void Dijkstra(int st)
	{
		Arrays.fill(we, 0);
		Arrays.fill(visited, false);
		Arrays.fill(num, 0);
		Arrays.fill(dis, INF);
		dis[st] = 0;
		num[st] = 1;
		we[st] = weight[st];
		for(int i=0; i<n; i++)
		{
			int MIN = INF;
			int k = -1;
			for(int j=0; j<n; j++)
			{
				if(!visited[j]&&dis[j]<MIN)
				{
					MIN = dis[j];
					k = j;
				}
			}
			if(k==-1) return;
			visited[k] = true;
			for(int j=0; j<n; j++)
			{
				if(!visited[j]&&dis[j]>dis[k]+G[k][j])
				{
					dis[j] = dis[k] + G[k][j];
					we[j] = we[k] + weight[j];
					num[j] = num[k];
				}else if(!visited[j]&&dis[j]==dis[k]+G[k][j])
				{
					if(we[j]<we[k]+weight[j])
					{
						we[j] = we[k] + weight[j];
					}
					num[j] += num[k];
				}
			}
		}
	}
}

C++代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXV = 510;
const int INF = 1000000000;

int n,m,st,ed,G[MAXV][MAXV],weight[MAXV];
int w[MAXV],d[MAXV],num[MAXV];
bool vis[MAXV] = {false};
void Dijkstra(int s)
{
    fill(d,d+MAXV,INF);
    memset(num,0,sizeof(num));
    memset(w,0,sizeof(w));
    w[s] = weight[s];
    num[s] = 1;
    d[s] = 0;
    for(int i=0; i<n; i++)
    {
        int MIN = INF;
        int v = -1;
        for(int j=0; j<n; j++)
        {
            if(vis[j]==false&&d[j]<MIN)
            {
                MIN = d[j];
                v = j;
            }
        }
        if(v==-1)
            return;
        vis[v] = true;
        for(int j=0; j<n; j++)
        {
            if(vis[j]==false&&G[v][j]!=INF)
            {
                if(G[v][j]+d[v]<d[j])
                {
                    d[j]=G[v][j]+d[v];
                    num[j]=num[v];
                    w[j]=w[v]+weight[j];
                }
                else if(G[v][j]+d[v]==d[j])
                {
                    if(w[v]+weight[j]>w[j])
                    {
                        w[j]=w[v]+weight[j];
                    }
                    num[j]+=num[v];
                }
            }
        }
    }
}

int main()
{
    int a,b,c;
    scanf("%d%d%d%d",&n,&m,&st,&ed);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&weight[i]);
    }
    fill(G[0],G[0]+MAXV*MAXV,INF);
    for(int i=0; i<m; i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        G[a][b] = c;
        G[b][a] = c;
    }
    Dijkstra(st);
    printf("%d %d",num[ed],w[ed]);
    return 0;
}

注意:当两条路径相等时,在对we[]进行优化时一定要判断we[j]<we[k]+weight[j]是否成立,因为你不知道会不会有第三条路径是we[j]更大,这是我之前犯的错误。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值