1010 Radix (25point(s))
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes
, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1
and N2
each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a
-z
} where 0-9 represent the decimal numbers 0-9, and a
-z
represent the decimal numbers 10-35. The last number radix
is the radix of N1
if tag
is 1, or of N2
if tag
is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1
= N2
is true. If the equation is impossible, print Impossible
. If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
题目大意:给两个数n1,n2,第三个数用i表示,第四个数用radix表示,代表ni的进制数。求另一个数的进制数是多少时可以让两个数相等,如果不可能输出Impossible。
解题思路:首先将给出进制的那个数求出来对应的十进制数,记作num,这里统一用long long类型;然后再使用二分法从[low, high]中寻找能使两个数相等的进制数,low代表最低进制,high直接取num。这道题关键是要用二分法查找,因为low和high距离可能过大,比如输入123456789 1 1 10时,low为2,high为123456789,相差过大,如果按顺序循环可能会超时...
Java代码:
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String n1 = sc.next();
String n2 = sc.next();
int tag = sc.nextInt();
long radix = sc.nextLong();
long result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) : find_radix(n1, convert(n2, radix));
if (result_radix != -1) {
System.out.println(result_radix);
} else {
System.out.println("Impossible");
}
}
static long find_radix(String n, long num) {
long low = '0';
for (int i = 0; i < n.length(); i++) {
if (low < n.charAt(i)) {
low = n.charAt(i);
}
}
low = (low >= 97 ? low - 'a' + 10 : low - '0') + 1;
long high = Math.max(low, num);
while (low <= high) {
long mid = (low + high) / 2;
long t = convert(n, mid);
if (t < 0 || t > num)
high = mid - 1;
else if (t == num)
return mid;
else
low = mid + 1;
}
return -1;
}
static long convert(String n, long radix) {
long sum = 0;
int temp = 0, index = 0;
for (int i = n.length() - 1; i >= 0; i--) {
temp = n.charAt(i) >= 'a' ? n.charAt(i) - 'a' + 10 : n.charAt(i) - '0';
sum += temp * Math.pow(radix, index++);
}
return sum;
}
}
C++代码:
#include <bits/stdc++.h>
using namespace std;
long long convert(string n, long long radix)
{
long long sum = 0;
int temp = 0, index = 0;
for(auto it = n.rbegin(); it != n.rend(); it++)
{
temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
sum += temp * pow(radix, index++);
}
return sum;
}
long long find_radix(string n, long long num)
{
char it = *max_element(n.begin(), n.end());
long long low = (isdigit(it) ? it - '0' : it - 'a' + 10) + 1;
long long high = max(num, low);
while(low <= high){
long long mid = (low+high)/2;
long long t = convert(n, mid);
if(t<0||t>num) high = mid - 1;
else if(t==num) return mid;
else low = mid + 1;
}
return -1;
}
int main()
{
string n1, n2;
long long tag = 0, radix = 0, result_radix;
cin >> n1 >> n2 >> tag >> radix;
result_radix = tag == 1 ? find_radix(n2, convert(n1, radix)) :
find_radix(n1, convert(n2, radix));
if(result_radix != -1){
printf("%lld", result_radix);
}else{
printf("Impossible");
}
return 0;
}