HDU-1016 Prime Ring Problem (素数圈) DFS全排列

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
 
 
6 8
 

Sample Output
 
 
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2


题目大意:

给定圈中元素的数量,输出素数圈(相邻两个元素奇偶性相反),然后按字典序升序输出


感受:

DFS搜索,一个个进行搜索匹配看看有没有符合条件的。

值得注意的是空格,还有

Print a blank line after each case.
 每一个例子之间需要一个换行符


AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

const int MAX=25;
bool vis[MAX];
int a[MAX],n;

bool isprime(int x)
{
	if(x==1)	return false;
	if(x==2)	return true;  //2是素数 
	if(x%2==0)	return false;
	for(int i=3;i<=sqrt(x);i+=2)  //i+=2 可以减少计算量 
	{
		if(x%i==0)	return false;
	}
	return true;
 } 

void dfs(int index)
{
	if(index==n&&isprime(a[n-1]+a[0]))    //最后还要判定这两个元素的奇偶性 
	{
		for(int i=0;i<n-1;i++)
			printf("%d ",a[i]);
		printf("%d\n",a[n-1]);	
	}
	
	for(int i=2;i<=n;i++)
	{
		a[index]=i;
		if(!vis[i]&&isprime(a[index]+a[index-1]))   //判定 
		{
			vis[i]=true;
			dfs(index+1);
			vis[i]=false;	
		}		
	}
	
 } 
 
 
int main()
{
	int num=1;
	while(~scanf("%d",&n))
	{
		cout<<"Case "<<num++<<":"<<endl;
		memset(vis,0,sizeof(vis));	
		a[0]=1;
		dfs(1);
		
		printf("\n");   //记得空开一行,被坑了 
	}
	return 0;
	
}
 




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值