Uva247 Floyd+dfs java

If you've seen television commercials for long-distance phone companies lately, you've noticed that many companies have been spending a lot of money trying to convince people that they provide the best service at the lowest cost. One company has calling circles." You provide a list of people that you call most frequently. If you call someone in your calling circle (who is also a customer of the same company), you get bigger discounts than if you call outside your circle. Another company points out that you only get the big discounts for people in your calling circle, and if you change who you call most frequently, it's up to you to add them to your calling circle.

LibertyBell Phone Co. is a new company that thinks they have the calling plan that can put other companies out of business. LibertyBell has calling circles, but they gure out your calling circle for you. This is how it works. LibertyBell keeps track of all phone calls. In addition to yourself, your calling circle consists of all people whom you call and who call you, either directly or indirectly.For example, if Ben calls Alexander, Alexander calls Dolly, and Dolly calls Ben, they are all within the same circle. If Dolly also calls Benedict and Benedict calls Dolly, then Benedict is in the same calling circle as Dolly, Ben, and Alexander. Finally, if Alexander calls Aaron but Aaron doesn't call Alexander, Ben, Dolly, or Benedict, then Aaron is not in the circle.You've been hired by LibertyBell to write the program to determine calling circles given a log of phone calls between people.

Input
The  input  file  will  contain  one  or  more  data  sets.   Each  data  set  begins  with  a  line  containing  two integers,n and m.The first integer,n, represents the number of different people who are in the data set.  The maximum value for
n is 25.  The remainder of the data set consists of m lines, each representing a phone call.  Each call is represented by two names, separated by a single space.  Names are rst names only (unique within a data set), are case sensitive, and consist of only alphabetic characters; no name is longer than 25 letters.
For example, if Ben called Dolly, it would be represented in the data file as
Ben Dolly
Input is terminated by values of zero (0) for n and m.

Output
For each input set,  print a header line with the data set number,  followed by a line for each calling circle in that data set.  Each calling circle line contains the names of all the people in any order within the circle, separated by comma-space (a comma followed by a space).  Output sets are separated by blank lines.

Sample Input
5 6
Ben Alexander
Alexander Dolly
Dolly Ben
Dolly Benedict
Benedict Dolly
Alexander Aaron
14 34
John Aaron
Aaron Benedict
Betsy John
Betsy Ringo
Ringo Dolly
Benedict Paul
John Betsy
John Aaron
Benedict George
Dolly Ringo
Paul Martha
George Ben
Alexander George
Betsy Ringo
Alexander Stephen
Martha Stephen
Benedict Alexander
Stephen Paul
Betsy Ringo
Quincy Martha
Ben Patrick
Betsy Ringo
Patrick Stephen
Paul Alexander
Patrick Ben
Stephen Quincy
Ringo Betsy
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Betsy Benedict
Quincy Martha
0 0

Sample Output
Calling circles for data set 1:
Ben, Alexander, Dolly, Benedict
Aaron
Calling circles for data set 2:
John, Betsy, Ringo, Dolly
Aaron
Benedict
Paul, George, Martha, Ben, Alexander, Stephen, Quincy, Patrick

题意:如果两个人互相打电话(直接或者间接),则说他们在同一个电话圈里。例如,a打给b,b打给c,c打给d,d打给a,则这四个人在同一个圈里;如果e打给f,而f不打给e,则不能推出e和f在同一个电话圈。输入n(n<=25)个人的m次电话,找出所有的电话圈。人名只包含字母,不超过25个字符,且不重复。

分析:本题一看就是求有向图的强连通分量问题。可以用tarjan解决。但是注意到数据比较小,还可以想到另外一个算法——floyd。在有向图中,有时不必关心路径的长度,只关心每两点之间是否有通路,则可以用1和0表示“连通”和“不连通”。这样,就可以用floyd解决了:dp[i][j]=dp[i][j]||(dp[i][k]&&dp[k][j])。这样的结果称为有向图的传递闭包(Transitive Closure)。

 

 

package _02___Floyd;

import java.util.ArrayList;
import java.util.HashSet;
import java.util.List;
import java.util.Scanner;
import java.util.Set;

public class Uva247 {
	
	public static int inv[],G[][];
	public static String[] s;
	public static Set set;
	public static int count = 0;
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()) {
		int n = sc.nextInt();
		int m = sc.nextInt();
		if(n==0&&m==0)break;
		s = new String[n];
		G = new int[n][n];
		//标记数组
		inv = new int[n];
		for (int i = 0; i < m; i++) {
			int i1 = strindex(s,sc.next());
			int j1 = strindex(s,sc.next());
			G[i1][j1] = 1;
		}
		falyd(G);
		//遍历数组
		for (int i = 0; i < n; i++) {
			for (int j = 0; j <= i; j++) {
				if(G[i][j]!=1||G[j][i]!=1) {
					G[i][j]=0;
					G[j][i]=0;
				}
			}
		}
		

		List<Set<String>> list = new ArrayList<>();
		for (int i = 0; i < G.length; i++) {
			if(inv[i]!=1) {
				set = new HashSet<String>();
				set.add(s[i]);
				inv[i] = 1;
				dfs(i);
				list.add(set);
			}
		}
		
		if(count>0)System.out.println();
		System.out.println("Calling circles for data set "+(++count)+":");
		for (Set sset : list) {
			for (int i = 0; i < sset.size(); i++) {
				System.out.print(sset.toArray()[i]);
				if(i!=sset.size()-1)System.out.print(", ");
			}
			System.out.println();
		}
		
		}

	}
	

	private static void dfs(int i) {
		for (int j = 0; j < G.length; j++) {
			if(inv[j]!=1&&G[i][j]==1) {
				set.add(s[j]);
				inv[j] = 1;
				dfs(j);
			}
		}
	}

	public static void falyd(int[][] G) {
		for (int k = 0; k < G.length; k++) {
			for (int i = 0; i < G.length; i++) {
				for (int j = 0; j < G.length; j++) {
					if(G[i][k]==1&&G[k][j]==1) {
						G[i][j] = 1;
					}
				}
			}
		}
	}
	
	public static int strindex(String str[],String s) {
		int i = 0;
		for (; i < str.length; i++) {
			if(str[i]==null||str[i].equals("")||str[i].equals(s))break;
		}
		str[i]=s;
		return i;
	}

}

 

 

PS:特别注意的是末尾不要换行。。。。。。。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值