NaOH计划组织一次讲座,为了保证每位来参加的同学都有椅子坐,他需要你帮他计算一下最少需要多少把椅子。
已知会有n个人来参加讲座,并且知道每个人体重。为了节约空间,每把椅子可以坐一个人或者两个人,椅子的承重为固定值。显然要求坐椅子的人的总重量不超过椅子的承重。
Input
第一行包含两个正整数n (0<n<=10000)和m (0<m<=2000000000),表示人数和椅子的承重。
接下来n行,每行一个正整数,表示每个人的体重,体重不超过1000000000。数据保证每个人的体重不超过m。
Output
一行一个整数,表示NaOH最少需要的椅子数。
Sample Input
3 6
1
2
3
Sample Output
2
思路:排序,最重的人和最轻的人坐,能坐就坐,不能坐就自己坐。即,左右指针,若能坐一起,head++;tail-;若不能,tail--
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int a[20000];
int main()
{
int num,max,count=0;
cin>>num>>max;
for(int i=0;i<num;i++)
cin>>a[i];
sort(a,a+num);
int head=0;
int tail=num-1;
while(head<=tail){
count++;
if(head==tail)
break;
else if(a[head]+a[tail]>max)
tail--;
else{
head++;
tail--;
}
}
cout<<count<<endl;
system("pause");
return 0;
}