HDU - 1241 Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

 

Sample Output

0
1
2
2

 题目大意:一快土地被分成很多小格,*代表没有油,@代表有油,有油的相邻小格(上,中,下,左下,右下,左上,右上)是一个油田里的油,输出油多少油田

解题思路:其实就是求不连通的@有多少,DFS秋求解

AC代码:

#include<iostream>
using namespace std;
int dir[8][2]={0,1,0,-1,1,0,-1,0,1,1,1,-1,-1,1,-1,-1};
char map[110][110];
int m,n;
void dfs(int x,int y)
{
	if(x>=0&&y>=0&&x<n&&y<m&&map[y][x]=='@')
	{
		map[y][x]='*';
		for(int i=0;i<8;i++)
		{
			int dx=x+dir[i][0];
			int dy=y+dir[i][1];
			dfs(dx,dy);
		}
	}
} 
int main()
{
	while(cin>>m)
	{
		int ans=0;
		if(m==0)
			break;
		cin>>n;
		for(int i=0;i<m;i++)
			cin>>map[i];
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)
		{
			if(map[i][j]=='@')//遇到就加一,然后使用dfs将相邻的@变为* 
			{
				ans++;
				dfs(j,i);
			}	
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值