Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).
Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.
Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.
Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.
Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1 1 3 10 2 4 20 2 3 3
Sample Output
27
Hint
Explanation of the sample:
There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.
The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
题目大意:有n个奶牛排成一排,其中有ml头奶牛相互喜欢,希望离的近点,有md头奶牛相互讨厌,希望离的远点, 输入n,ml,md;然后接着ml行三个整数u,v,w,表示奶牛u和奶牛v的最远距离不超过w;然后md行,每行三个整数u,v,w;表示奶牛u和奶牛v的最近距离不小于w;
求1号牛和n号牛的最大距离,如果距离无限大输出-2,如果无解输出-1。
解题思路:差分约束,SPFA求解
差分约束:https://blog.csdn.net/zhang20072844/article/details/7788672
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=1e5;
const int INF=0x3f3f3f3f;
struct node{
int to;
int w;
int next;
}e[maxn];
int head[maxn],cnt,n,ml,md;
int dis[maxn],vis[maxn],cot[maxn];
void add(int u,int v,int w)
{
e[cnt].to=v;
e[cnt].w=w;
e[cnt].next=head[u];
head[u]=cnt++;
}
void init()
{
cnt=0;
memset(dis,INF,sizeof(dis));
memset(vis,0,sizeof(vis));
memset(cot,0,sizeof(cot));
memset(head,-1,sizeof(head));
}
void SPFA()
{
dis[1]=0;
queue<int> q;
q.push(1);
int flag=0;
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
if(cot[u]++>n)
{
flag=1;
break;
}
for(int i=head[u];~i;i=e[i].next)
{
int to=e[i].to;
int w=e[i].w;
if(dis[to]>dis[u]+w)
{
dis[to]=dis[u]+w;
if(vis[to]==0)
{
q.push(to);
vis[to]=1;
}
}
}
}
if(flag==1)
printf("-1\n");
else if(dis[n]==INF)
printf("-2\n");
else
printf("%d\n",dis[n]);
}
int main()
{
while(~scanf("%d%d%d",&n,&ml,&md))
{
int u,v,w;
init();
for(int i=0;i<ml;i++)
{
scanf("%d%d%d",&u,&v,&w);
add(u,v,w);
}
for(int i=0;i<md;i++)
{
scanf("%d%d%d",&u,&v,&w);
add(v,u,-w);
}
SPFA();
}
return 0;
}