年龄排序.

题目描述
​ 输入n个学生的信息,包括姓名、性别、出生年月。

​ 要求按年龄从小到大一次输出这些学生的信息。

​ 数据保证没有学生同年同月出生。

输入
​ 第一行一个整数n,表示学生人数,n≤100。

​ 接下来n行,每一行依次输入学生的姓名、性别、出生年份。出生月份。

输出
​ 按年龄从小到大,一行输出一个学生的原始信息。

样例输入
5
John male 1999 12
David female 1999 8
Jason male 1998 11
Jack female 1998 8
Kitty female 2000 7
样例输出
Kitty female 2000 7
John male 1999 12
David female 1999 8
Jason male 1998 11
Jack female 1998 8
数据规模与约定
​ 时间限制:1 s

​ 内存限制:256 M

​ 100% 的数据保证 1≤n≤100

#include <iostream>
#include <algorithm>
using namespace std;

struct student {
	string name;
	string sex;
	int year;
	int month;
};
bool cmp(student a, student b) {
	if (a.year == b.year) {
		return a.month > b.month;
	}
	return a.year > b.year;
}
int main() {
	student stu[105];
	int n;
	cin >> n;
	for(int i = 0; i < n; i++)
	cin >> stu[i].name >> stu[i].sex >> stu[i].year>> stu[i].month;
	sort(stu, stu + n, cmp);
	for (int i = 0; i < n; i++)
		cout << stu[i].name << " " << stu[i].sex << " " << stu[i].year 
	 << " " << stu[i].month << endl;
	return 0;
}
#include <iostream>
using namespace std;

struct student {
	string name;
	string sex;
	int year;
	int month;
};

int main() {
	student stu[105];
	int n;
	cin >> n;
	for(int i = 0; i < n; i++)
	cin >> stu[i].name >> stu[i].sex >> stu[i].year>> stu[i].month;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n - i-1; j++) {
			if (stu[j].year < stu[j + 1].year || 
				(stu[j].year == stu[j + 1].year && stu[j].month < stu[j + 1].month)) {
				swap(stu[j], stu[j + 1]);
			}
		}
	}
	for (int i = 0; i < n; i++)
		cout << stu[i].name << " " << stu[i].sex << " " << stu[i].year 
	 << " " << stu[i].month << endl;
	return 0;
}
#include <iostream>
using namespace std;

struct student {
	string name;
	string sex;
	int year;
	int month;
};

int main() {
	student stu[105];
	int n;
	cin >> n;
	for(int i = 0; i < n; i++)
	cin >> stu[i].name >> stu[i].sex >> stu[i].year>> stu[i].month;
	for (int i = 0; i < n; i++) {
		for (int j = i; j < n ; j++) {
			if (stu[i].year < stu[j].year || 
				(stu[i].year == stu[j].year && stu[i].month < stu[j].month)) {
				swap(stu[i], stu[j]);
			}
		}
	}
	for (int i = 0; i < n; i++)
		cout << stu[i].name << " " << stu[i].sex << " " << stu[i].year 
	 << " " << stu[i].month << endl;
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

yitahutu79

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值