Lowest Common Multiple Plus----杭电

Problem Description
求n个数的最小公倍数。
 

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 

Sample Input
 
  
2 4 63 2 5 7
 

Sample Output
 
 
1270
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<math.h>
#include<cstring>
using namespace std;
int g(int a,int b)
{
    if(b==0)
        return a;
    else
        return g(b,a%b);
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int t;
        scanf("%d",&t);
        for(int i=1; i<n; i++)
        {
            int t2;
            scanf("%d",&t2);
            t=t/g(t,t2)*t2;
        }
        printf("%d\n",t);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值