hdu1247(字典树)

Hat’s Words Time Limit: 2000/1000 MS (Java/Others) Memory Limit:
65536/32768 K (Java/Others) Total Submission(s): 16086 Accepted
Submission(s): 5737

Problem Description A hat’s word is a word in the dictionary that is
the concatenation of exactly two other words in the dictionary. You
are to find all the hat’s words in a dictionary.

Input Standard input consists of a number of lowercase words, one per
line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output Your output should contain all the hat’s words, one per line,
in alphabetical order.

Sample Input
a ahat hat hatword hziee word

Sample Output
ahat

题意:
如果一个单词能被另外两个单词拼接,则输出
用字典树维护
代码

#include <bits/stdc++.h>

using namespace std;

typedef struct node
{
    int flag;
    node *child[26];
    node()
    {
        flag=0;
        for(int i=0;i<26;i++)
        {
            child[i]=NULL;
        }
    }
}Tree,node;
void insert(Tree *head,char *s)
{
    node *t=head;
    int index,len;
    len=strlen(s);
    for(int i=0;i<len;i++)
    {
        index=s[i]-'a';
        if(t->child[index] ==NULL)
        {
            t->child[index]= new node();
        }
        t=t->child[index];
    }
    t->flag=1;
}
int search(char *ss,Tree *head)
{
    node *t=head;
    int index,k;
    k=0;
    for(int i=0;ss[i]!='\0';i++)
    {
        index=ss[i]-'a';
        if(t->child[index]==NULL)
        {
            return 0;
        }
        t=t->child[index];

    }
    return t->flag;
}
int main()
{
    Tree *head= new Tree();
    char s[50005][20];
    int cnt=0;
    printf("*\n");
    while(scanf("%s",s[cnt])==1)
    {
        insert(head,s[cnt]);
        cnt++;
    }

    for(int i=0;i<cnt;i++)
    {
        int len=strlen(s[i]);
        for(int j=1;j<len;j++)
        {
            //复制两个字符串
            char s1[20],s2[20];
            int k;
            for( k=0;k<j;k++)
            {
                s1[k]=s[i][k];
            }
            s1[k]='\0';
            int kk=0;
            for( k=j;k<len;k++)
            {
                s2[kk++]=s[i][k];
            }
            s2[kk]='\0';
            //查找两个字符串
            if(search(s1,head) && search(s2,head))
            {
                printf("%s\n",s[i]);
                break;
            }
        }
    }
    return 0;
}
//a ahat hat hatword hziee word

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值