hdu1251(字典树)

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output
对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input
banana band bee absolute acm

(换行)
ba b band abc
Sample Output
2 3 1 0

题意比较简单
思路:用字典树,但是实现方式有两种,用链表的话会内存超限,用数组实现就可以ac
链表实现:

#include <bits/stdc++.h>

using namespace std;
typedef struct node
{
    int flag;
    node *child[26];
    node()
    {
        flag=0;
        for(int i=0;i<26;i++)
        {
            child[i]=NULL;
        }
    }
}Tree,node;
void insert(Tree *head,char *s)
{
    node *t=head;
    int index,len;
    len=strlen(s);
    for(int i=0;i<len;i++)
    {
        index=s[i]-'a';
        if(t->child[index]==NULL)
            t->child[index]=new node;
        t=t->child[index];
        (t->flag)++;
    }

}

int search(Tree *head,char *s)
{
    node *t=head;
    int index,len;
    len=strlen(s);
    for(int i=0;i<len;i++)
    {
        index=s[i]-'a';
        if(t->child[index]==NULL)
            return 0;
        t=t->child[index];
    }

    return t->flag;
}
int main()
{
    char word[20];
    Tree *tree= new Tree();
    while(gets(word))
    {
        if(word[0]=='\0')break;
        insert(tree,word);
    }
    while(scanf("%s",word)!=EOF)
    {
        printf("%d\n",search(tree,word));
    }
    return 0;
}
/*

banana
band
bee
absolute
acm

ba
b
band
abc


*/

数组实现:

#include <iostream>
#include <stdio.h>
using namespace std;

int trie[1000010][26];    //数组形式定义字典树,值存储的是下一个字符的位置
int num[1000010]={0};    //附加值,以某一字符串为前缀的单词的数量
int pos = 1;

void Insert(char word[])    //在字典树中插入某个单词
{
    int i;
    int c = 0;
    for(i=0;word[i];i++){
        int n = word[i]-'a';
        if(trie[c][n]==0)    //如果对应字符还没有值
            trie[c][n] = pos++;
        c = trie[c][n];
        num[c]++;
    }
}
int Find(char word[])    //返回以某个字符串为前缀的单词的数量
{
    int i;
    int c = 0;
    for(i=0;word[i];i++){
        int n = word[i]-'a';
        if(trie[c][n]==0)
            return 0;
        c = trie[c][n];
    }
    return num[c];
}

int main()
{
    char word[11];
    while(gets(word)){
        if(word[0]==NULL)    //空行。gets读入的回车符会自动转换为NULL。
            break;
        Insert(word);
    }
    while(gets(word))
        printf("%d\n",Find(word));
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值