hdu1541(树状数组)

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5 1 1 5 1 7 1 3 3 5 5

Sample Output

1 2 1 1 0

题目大意:

我感觉有点难理解,但看了别人的解释还是懂了,输入n个星星的坐标(x,y),y是非递减的,求星星的等级,输出等级0的有几个,等级1的有及格,等级2的有几个.....直到n。

那么如何算星星的等级呢?

看样例的图,这颗星星的右下方以及下方的星星数量就是等级(不包括自己)

那么也就是x轴小于等于这颗星星的有几个,那么就是等级几(不包括自己)

思路:

按题意就是求[1,x]的区间和,并且会增加数据,那么就可以用树状数组维护,(发现其实y是没有用的,因为y是递增的)

最后输出时,要注意是先update还是先getsum,对答案是有影响的

树状数组是从1开始,题目的x是从0开始,这点要注意即可

代码:先getsum,再update

#include <bits/stdc++.h>

using namespace std;

int n;
int c[32005];
int ans[15005];
int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int k)
{
    for(;i<=32005;i+=lowbit(i))
        c[i] += k;


}
int getsum(int k)
{
    int sum=0;
    for(int i=k;i>0;i-=lowbit(i))
        sum+=c[i];
    return sum;
}
int main()
{
    int a,b,level;
    while(scanf("%d",&n)==1)
    {
        memset(c,0,sizeof c);
        memset(ans,0,sizeof ans);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a,&b);
//            update(a+1,1);//树状数组都是从1开始,而这里从0开始
            level=getsum(a+1);//树状数组都是从1开始,而这里从0开始
            ans[level]++;

            update(a+1,1);//树状数组都是从1开始,而这里从0开始

        }
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}

先update再getsum

#include <bits/stdc++.h>

using namespace std;

int n;
int c[32005];
int ans[15005];
int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int k)
{
    for(;i<=32005;i+=lowbit(i))
        c[i] += k;


}
int getsum(int k)
{
    int sum=0;
    for(int i=k;i>0;i-=lowbit(i))
        sum+=c[i];
    return sum;
}
int main()
{
    int a,b,level;
    while(scanf("%d",&n)==1)
    {
        memset(c,0,sizeof c);
        memset(ans,0,sizeof ans);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            update(a+1,1);//树状数组都是从1开始,而这里从0开始
            level=getsum(a+1);//树状数组都是从1开始,而这里从0开始
            ans[level-1]++;

//            update(a+1,1);//树状数组都是从1开始,而这里从0开始

        }
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值