Corn Fields

Corn Fields

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:

1 2 3
 4  

题意:

农田里面有被1和0标记的方格,1为可以放牧,0为不可以放牧,并且不可以在相邻的两个方格里面放牧(包括每一行里面相邻以及每一列里面的相邻,不包括斜线相邻)。

用状态dp:

&  按位与两位同时为1则为1,否则为00&0=0;  0&1=0;   1&0=0;    1&1=1;
|按位或两者只要一个为1则为10|0=0;  0|1=1;  1|0=1;   1|1=1
<<左移运算符将一个运算对象的各二进制位全部左移若1位,相当于乘以2 
>>右移运算符将一个运算对象的个二进制位全部右移一位,相当于除以2 

 

#include <bits/stdc++.h>
using namespace std;
int N = 13,M=1<<N,mod=100000000;
//st 存放每一行的状态,即在没有相邻的情况下 
int st[M],map[M];
//map表示第i行整体状况 
int dp[N][M];

//判断状态x是否可行,存在相邻两个各自都为1,则状态不行 
bool jugle(int x){
	return(x&(x<<1));
}

//判断上下是否有相邻现象 
bool jugle2(int i,int x){
	return (map[i]&st[x]);
}

int main(){
	int n,m,x;
	while(~scanf("%d%d",&n,&m)){
		memset(st,0,sizeof(st));
		memset(map,0,sizeof(map));
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			for(int j =1;j<=m;j++){
				scanf("%d",&x);
				if(x==0)      //如果该区域为0 
					map[i] +=(1<<(j-1)); 
					//该位置为1,(注意以相反位置存储 ,即1不能存储)
			}
		}		
		int k=0;
		for(int i=0;i<k;i++){
			if(!jugle2(1,i)){  //判断每一行和第1行状态是否有重合 
				dp[1][i] = 1;   
			}
		}
		for(int i=2;i<=n;i++){
			for(int j=0;j<k;j++){
				if(judgle2(i,j))// 判断每一行和第i行状态是否有重合 
					continue;
				for(int o = 0;o<k;o++){
					if(!st[j] && st[o])//判断是否和隔壁发生冲突 
						dp[i][j]+=dp[i-1][o];//如果都没有可以累加 
				}
			}
		}
		int ans = 0;
		for(int i=0;i<k;i++){
			ans+=dp[n][i];
			ans %= mod;			
		}
		printf("%d\n",ans);
	}	
	
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值