第十届河南省acm省赛 Binary to Prime

F: Binary to Prime

时间限制: 1 Sec  内存限制: 128 MB
提交: 21  解决: 13
[提交][状态][讨论版]

题目描述

To facilitate the analysis of  a DNA sequence,  a DNA sequence is represented by a binary  number. The group of  DNA-1 has discovered a great new way .  There is a certain correlation between binary number and prime number. Instead of using the ordinary decadic numbers, they use prime base numbers. Numbers in this base are expressed as sequences of zeros and ones similarly to the binary numbers, but the weights of bits  in the representation are not powers of two, but the elements of the primes  ( 2, 3, 5, 7,... ).

 

For example  01101 , ie. 2+5+7=14

 

Herefore, it is necessary to convert the binary number to the sum of prime numbers 

输入

The input consists of several instances, each of them consisting of a single line. Each line of the input contains a 01 string, length of not more than 150.  The end of input is not marked in any special way.

输出

For each test case generate a single line containing a single integer , The sum of the primes.

样例输入

 
000010
0011
11001

样例输出

 
3
5
20

虽然题没咋看懂但是大致看数字看懂了,说的是每一次输入都是一个特殊进位的数,最末尾对应的是最小的质数2,倒数第二位对应的是第二小的质数3,以此类推;

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int su(int i)
{
    int k=(int)sqrt(i);
    for(int j=2;j<=k;j++){
        if(i%j==0)return 0;
    }
    return 1;
}
int main()
{
    int a[200]={0};
    int j=1;
    for(int i=2;;i++){
        if(su(i))
            a[j++]=i;
        if(j>155)
            break;
    }
    char str1[160];
    while(~scanf("%s",str1))
    {
        int len1=strlen(str1);
        int sum=0;
        j=1;
        for(int i=len1-1;i>=0;i--){
            if(str1[i]=='1')sum+=a[j];
            j++;
        }
        cout<<sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值