第四届河南省程序设计大赛 ——Substring

题目描述:

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入描述:

The first line of input gives a single integer, 1 ≤ N ≤ 10,  the number of test cases. Then follow, for each test case,  a  line  containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').

输出描述:

Output for each test case  the longest substring of input such that the reversal of the substring is also a substring of input

样例输入:

复制

3                   
ABCABA
XYZ
XCVCX

样例输出:

ABA
X
XCVCX

 

这一题最保险的方法就是使用将输入的字符串反转后求两个字符串的最大公共连续子序列

如果暴力的话,需要注意这用测试用例——XBCDEFYWFEDCBZ  这个测试用例的答案是BCDEF

 

解题代码:(暴力)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#define INF 9999999;
using namespace std;
string s;
bool lst(string s1){   //判断子串s1在原来的字符串中是否能找到相同项
    for(int i=0;i+s1.size()<=s.size();i++){
    	int bj=1;
	    for(int j=i;j<i+s1.size();j++){
		    if(s1[j-i]!=s[j]){
		    	bj=0;
		    	break;
		    }
		}  
		if(bj)return true;  
	}
	return false;	
}
int main(){
	int n;
	cin>>n;
	while(n--){
		cin>>s; 
		int bj=1;
		for(int i=s.size();i>0&&bj;i--){
		    for(int j=0;j+i-1<s.size();j++){
		    	string s1;
				for(int k=i-1;k>=0;k--)s1+=s[j+k]; //将所有可能的子串s1判断
				if(lst(s1)){
					for(int i=s1.size()-1;i>=0;i--)cout<<s1[i];  //若成立,则将子串s1反转输出
					cout<<endl;
					bj=0;
					break;
				}
		    }
		    
	    }
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值