迷宫问题 bfs

Input 
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output 
左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
  •  

Sample Output

8

第二次看的时候才发现一次 只能进行四次的移动的尝试   

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define N 5
int a[N][N];
int vis[N][N];
int dir[4][2]= {0,1,0,-1,-1,0,1,0};
struct node {
    int x,y,step;
};
int bfs(int x0,int y0,int x1,int y1) {
    queue<node>q;
    node fr,ne;
    fr.x=x0;
    fr.y=y0;
    fr.step=0;
    q.push(fr);
    while(!q.empty()) {
        fr=q.front();
        q.pop();
        if(fr.x==x1&&fr.y==y1) {
            return fr.step;
        }
        for(int i=0; i<4; i++) {
            ne.x=fr.x+dir[i][0];
            ne.y=fr.y+dir[i][1];
            ne.step=fr.step+1;
            if(ne.x>=0&&ne.x<5&&ne.y>=0&&ne.y<5&&vis[ne.x][ne.y]==0) {
                vis[ne.x][ne.y]=1;
                q.push(ne);
            }
        }
    }
}

int main() {
    memset(vis,0,sizeof(vis));
    for(int i=0; i<N; i++) {
        for(int j=0; j<N; j++) {
            scanf("%d",&a[i][j]);
            if(a[i][j]==1)
                vis[i][j]=1;
        }
    }
    int re=    bfs(0,0,N-1,N-1);
    printf("%d\n",re);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值