找回文串 MOD10007

In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>. 
(http://en.wikipedia.org/wiki/Subsequence) 

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <Sy1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.

Input

The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.

Output

For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.

Sample Input

4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems

Sample Output

Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960

思路:

数组dp[i][j]记录的是从i到j有多少个回文串,可以推出状态转移方程dp[i][j]=dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1];如果两个字符相等的话,则要再加上dp[i+1][j-1]+1(加一就是只剩下左右两个相等的中间的全去掉,还有就是有相减的要先加上10007再取模,否则)可能会有负数。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <string>
using namespace std;

int dp[1005][1005];
char s[1005];
int main()
{
int T;
while(cin>>T)
{
    int q=1;
    while(T--)
    {
        cin>>s;
        int n=strlen(s);
        memset(dp,0,sizeof dp);
        for(int j=0;j<n;j++)
        {
            for(int i=j;i>=0;i--)//这里稍微注意一下,要倒着枚举。
            {
                dp[i][j]=(dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1]+10007)%10007;
                if(s[i]==s[j])
                    {dp[i][j]+=dp[i+1][j-1]+1;}
                    dp[i][j]%=10007;
            }
        }
        printf("Case %d: %d\n",q++,dp[0][n-1]);
    }
}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值