There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:
Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.
Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci≤ 100).
It is guaranteed that the sum of all n does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.
Output
For each case, you should output one integer denoting the maximum comfort.
Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint
For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.
的两边同除以segema(Hxi)会发现在segema(Cxi)相同的情况下,segema(Hxi)的值越大,答案也就越大。
01 背包:f[i]表示选中的Ci的总数为i的Hi的总和的最大值。
#include<bits/stdc++.h>
#define ll long long
using namespace std;
const ll maxn=50009;
ll f[maxn];
ll h[506];
ll c[506];
int main()
{
ll t;
cin>>t;
while(t--)
{
ll n;
cin>>n;
ll sum=0;
for(ll i=1;i<=n;i++)
{
cin>>h[i]>>c[i];
sum+=c[i];
}
memset(f,0,sizeof(f));
for(ll i=1;i<=n;i++)
{
for(ll j=sum;j>=c[i];j--)
{
f[j]=max(f[j],f[j-c[i]]+h[i]);
}
}
ll ans=0;
for(ll i=0;i<=sum;i++)
{
ans=max(ans,f[i]*f[i]-i*i-i*f[i]);
}
cout<<ans<<endl;
}
}