Problem Statement
Snuke has decided to play a game using cards. He has a deck consisting of NN cards. On the ii-th card from the top, an integer AiAi is written.
He will perform the operation described below zero or more times, so that the values written on the remaining cards will be pairwise distinct. Find the maximum possible number of remaining cards. Here, NN is odd, which guarantees that at least one card can be kept.
Operation: Take out three arbitrary cards from the deck. Among those three cards, eat two: one with the largest value, and another with the smallest value. Then, return the remaining one card to the deck.
Constraints
- 3≦N≦1053≦N≦105
- NN is odd.
- 1≦Ai≦1051≦Ai≦105
- AiAi is an integer.
Input
The input is given from Standard Input in the following format:
NN A1A1 A2A2 A3A3 ... ANAN
Output
Print the answer.
Sample Input 1 Copy
Copy
5 1 2 1 3 7
Sample Output 1 Copy
Copy
3
One optimal solution is to perform the operation once, taking out two cards with 11 and one card with 22. One card with 11 and another with 22 will be eaten, and the remaining card with 11 will be returned to deck. Then, the values written on the remaining cards in the deck will be pairwise distinct: 11, 33 and 77.
Sample Input 2 Copy
Copy
15 1 3 5 2 1 3 2 8 8 6 2 6 11 1 1
Sample Output 2 Copy
Copy
7
题意:
有n个数每次你可以拿出其中的三个然后扔掉最大的,和最小的把剩余那一个重新放回去(次数不限)。问你最多可以剩多少个使的剩余的数都不相同。
思路:
先用set判断出有多少个不同的元素记为m,n-m如果为奇数就输出m,否则输出m-1。自己模拟一下就知道了。
代码:
#include<bits/stdc++.h>
using namespace std;
set<int> s;
int main()
{
int n;
cin>>n;
int x;
for(int i=1;i<=n;i++)
{
cin>>x;
s.insert(x);
}
int sum=s.size();
int t=n-sum;
if(t%2==0)
{
cout<<sum<<endl;
}
else
{
cout<<sum-1<<endl;
}
}