C - Reconciled?(组合数学)

Problem Statement

Snuke has NN dogs and MM monkeys. He wants them to line up in a row.

As a Japanese saying goes, these dogs and monkeys are on bad terms. ("ken'en no naka", literally "the relationship of dogs and monkeys", means a relationship of mutual hatred.) Snuke is trying to reconsile them, by arranging the animals so that there are neither two adjacent dogs nor two adjacent monkeys.

How many such arrangements there are? Find the count modulo 109+7109+7 (since animals cannot understand numbers larger than that). Here, dogs and monkeys are both distinguishable. Also, two arrangements that result from reversing each other are distinguished.

Constraints

  • 1≤N,M≤1051≤N,M≤105

Input

Input is given from Standard Input in the following format:

NN MM

Output

Print the number of possible arrangements, modulo 109+7109+7.


Sample Input 1 Copy

Copy

2 2

Sample Output 1 Copy

Copy

8

We will denote the dogs by A and B, and the monkeys by C and D. There are eight possible arrangements: ACBDADBCBCADBDACCADBCBDADACB and DBCA.


Sample Input 2 Copy

Copy

3 2

Sample Output 2 Copy

Copy

12

Sample Input 3 Copy

Copy

1 8

Sample Output 3 Copy

Copy

0

Sample Input 4 Copy

Copy

100000 100000

Sample Output 4 Copy

Copy

530123477

题意:
有n个猴子,m条狗。要求相邻的位不同物种,问你共有多少种排列。

代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
const ll mod=1e9+7;
ll a[100009];
void init()
{
    a[0]=1;
    for(int i=1;i<=100001;i++)
    {
        a[i]=a[i-1]*i;
        a[i]%=mod;
    }
}
int main()
{
    int n,m;
    cin>>n>>m;
    init();
    if(abs(n-m)>1)
    {
        cout<<0<<endl;
    }
    else
    {
        ll sum;
        if((n+m)%2==0)
        {
            sum=2*a[n]*a[n];
            sum%=mod;
        }
        else
        {
            sum=a[m]*a[n];
            sum%=mod;
        }
        cout<<sum<<endl;
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值