@[TOC](【PAT A1065】A+B and C(64bit))
Question Description
Given three integers A, B and C in [−2^63 ,2^63], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
Reference Code
#include<cstdio>
int main() {
int N;
scanf("%d", &N);
for (int i = 0; i < N; i++) {
long long A, B, C;
scanf("%lld %lld %lld", &A, &B, &C);
long long result = A + B;
if (A > 0 && B > 0 && result < 0 )printf("Case #%d: true\n", i + 1);//A+B 正溢出
else if (A < 0 && B < 0 && result >= 0) printf("Case #%d: false\n", i + 1); //A+B 负溢出
else if ( result > C) printf("Case #%d: true\n", i + 1); //大于C
else printf("Case #%d: false\n", i + 1); //A+B<=C
}
return 0;
}
Operation result