问题 F: 字符串的修改

题目描述
设A和B是两个字符串。我们要用最少的字符操作次数,将字符串A转换为字符串B。这里所说的字符操作共有三种:

  1. 删除一个字符;
  2. 插入一个字符;
  3. 将一个字符改为另一个字符。
    对任给的两个字符串A和B,计算出将字符串A变换为字符串B所用的最少字符操作次数。

输入
第一行为字符串A;第二行为字符串B;字符串A和B的长度均小于200。

输出
只有一个正整数,为最少字符操作次数。

样例输入
sfdxbqw
gfdgw

样例输出
4

import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        String strA = cn.nextLine();
        String strB = cn.nextLine();
        System.out.println(getDistance(strA,strB));
        cn.close();
    }
    public static int getDistance(String strA, String strB){
        if (strA.equals(strB)) {
        }
        int lengthA=strA.length();
        int lengthB=strB.length();
        int length=Math.max(lengthA,lengthB);
        int array[][]=new int[length+1][length+1];
        for(int i=0;i<=length;i++){
            array[i][0]=i;

        }
        for(int j=0;j<=length;j++){
            array[0][j]=j;
        }


        for(int i=1;i<=lengthA;i++){
            for(int j=1;j<=lengthB;j++){
                array[i][j]=min(array[i-1][j]+1,
                                array[i][j-1]+1,
                                array[i-1][j-1]+(strA.charAt(i-1)==strB.charAt(j-1)?0:1));
            }
        }
        return array[lengthA][lengthB];
    }
    public static int  min(int a,int b, int c){
        return Math.min(Math.min(a,b),c);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值