1054 求平均值

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

总结:

数字与字符串之间的转换判断。

代码:

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <cstring>

using namespace std;

int main()
{
	int n;
	cin >> n;
	
	double numSum = 0.0;
	int cnt = 0;
	
	for(int i=0;i<n;i++) {
		
		char textStr[50], numStr[50];
		double num;
		int flag = 0;
		
		scanf("%s", textStr);				// 输入 测试字符串 
		sscanf(textStr, "%lf", &num);			// 将 字符串 转化成 数字类型 
		sprintf(numStr, "%.2lf", num);			// 将 数字类型 再次 转换成 字符串类型 
		
		// 判断 测试字符串 和 结果字符串 的区别,取 测试字符串 的长度,可以省去小数点后长度的判断
		for(int j=0;j<strlen(textStr);j++) {	
			if( textStr[j] != numStr[j] ) {			
				flag = 1;
				break;
			}
		}
		
		// 清除不和标准的数字 
		if( flag == 1 || num < -1000 || num > 1000 )
			printf("ERROR: %s is not a legal number\n",textStr); 
		
		// 累加 
		else {
			cnt++;
			numSum += num;
		}			
	} 
	
	if(cnt == 0)
		printf("The average of 0 numbers is Undefined\n");
	else if(cnt == 1)
		printf("The average of 1 number is %.2lf\n",numSum);
	else
		printf("The average of %d numbers is %.2lf\n",cnt, numSum/cnt);
	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值