Stones

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12
题目大意:在路上不同的位置上有许多石头,每个石头都有能扔的最远距离。并且当石头的位置
一样时选择能扔最远的,遇到第奇数个石头扔,遇到偶数时不扔。
例如第一组数据
location  distance
1             5
2             4


小明扔了第一个石头此时石头位置变为6,在行走的过程中遇到
2位置的石头,由于是第偶数个,故不扔。当走到6位置是,又遇到了
第一次扔过去的石头,此时变为第3个遇到的石头再扔6,故最远距离为11
#include<stdio.h>
#include<iostream>
#include<queue>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
	{
		int loca,distan;
	}st;
bool operator < (const node &a,const node &b)
{
	if (a.loca==b.loca)
		return a.distan > b.distan;
	else
		return a.loca > b.loca;
}
int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n;
		scanf("%d",&n);
		priority_queue<node> q;
		for (int i=0;i<n;i++)
		{
			scanf("%d %d",&st.loca,&st.distan);
			q.push(st);
		}
		int ans = 1;
		int max = 0;
		while (!q.empty())
		{
			st = q.top();
			q.pop();
			if (ans&1)
			{
				st.loca += st.distan;
				max = st.loca;
				q.push(st);
			}
			ans++;
		}
		printf("%d\n",max);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值