Beauty of Array(找规律)

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

【分析】题意为,计算一个序列的连续子序列的和,并且如果有相等的数字的话,只加一次。

e.g. 如序列 1 2 3 4 3
    

以1结尾:1

sum[1]=1=(1-0)*1

以2结尾:12  2

sum[2]=1+2+2=sum[1]+2*2=sum[1]+(2-0)*2

以3结尾:123  23  3

sum[3]=1+2+3+...=sum[2]+3*3=sum[2]+(3-0)*3

以4结尾:1234  234  34  4

sum[4]=1+2+3+...=sum[3]+4*4=sum[3]+(4-0)*4
以3结尾:12343  2343  343  43  3   sum[5]=1+2+3+...=sum[4]+2*3=sum[4]+(5-3)*3
  

sum[i]=sum[i-1] + (i - pos[x] )*x;    //上一次的和+(该位置-该数上一次出现的位置)*该数(pos均初始为0,i 从1开始)

 

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
int pos[100010];

int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n,x;
		ll sum = 0,ans = 0;
		scanf("%d",&n);
		memset(pos,0,sizeof(pos));
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			sum += (i-pos[x]) * x;
			ans += sum;
			pos[x] = i;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值