Min Number

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029

只要注意一点0不能放在第一个位置就行啦

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace  std;
char a[1010];

int main()
{
	int t,m;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%s %d",a,&m);
		int len = strlen(a);
		int cnt = 0,k;//k记录最小数字的位置 
		char c;
		for (int i=0;i<len-1;i++)
		{
			int f = 0;
			c = a[i];
			for (int j=i+1;j<len;j++)
			{
				if (c>a[j])
				{//排除0在首位置的情况 
					if (i==0 && a[j]=='0')
						continue;
					else
					{
						f = 1;//判断是否进行了替换 
						k = j;
						c = a[j];
					}
				}
			}
			if (cnt>=m) break;//如果替换次数够了就退出循环 
			if (f==1)
			{
				swap(a[i],a[k]);
				cnt++;	
			}
		}
		printf("%s\n",a);
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值