zcmu1544: Counting Words

Description

DongDong prefers English words to English sentences, so he wants to count the words of a sentence. Could you help him?

Input

The first line contains a positive integer T (T<=1000), which means T test cases. Then comes T lines, each line contains a string which combines with several words separated by spaces. Note that there may be more than one space to separate two words.

Output

For each test case, please print the number of words of the sentence.

Sample Input

3 Every night in my dreams   I see you  I feel you   That  is  how I know you go on

Sample Output

568

HINT

Source

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	char a[1000];
	
	scanf("%d",&n);
	getchar();
	while(n--)
	{
	  gets(a);
	  int i,len,count=0;
	  len=strlen(a);
	  if(a[0]==' ')
	  {
	  	for(i=1;i<len;i++)
	  	{
	  		if(a[i]!=' '&&a[i-1]==' ')
	  		count++;
		  }
	 }
	  if(a[0]!=' ')
	  {
	  	count=1;
	  	for(i=1;i<len;i++)
	  	{
	  		if(a[i]!=' '&&a[i-1]==' ')
	  		count++;
		  }
	  }
	  printf("%d\n",count);
	}
	return 0;
 } 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值